Ask Your Question
2

Cursor keys scroll document in Calc instead of moving

asked 2017-02-14 21:41:44 +0200

normann gravatar image

updated 2017-02-14 21:42:03 +0200

After upgrading to LibreOffice 5.3.0.3 from 5.2, my 4 cursor keyboard keys in LibreOffice Calc has changed behavior. Instead of changing the active cell (by moving the black rectangle), they instead scroll the document (e.g. if columns A-V are currently shown on my screen, pressing the right cursor key scroll the document so that columns B-W are shown instead). Has anyone experienced this? I can't find a bug report on this behavior anywhere, and I don't believe it's a general bug as it renders the program more or less unusable and releasing a program with such a bug doesn't seem realistic. But I can't figure out why this behavior has suddenly started. Does anyone have ideas on what causes this behavior?

edit retag flag offensive close merge delete

10 Answers

Sort by » oldest newest most voted
2

answered 2017-06-08 09:27:29 +0200

gbu gravatar image

SOLVED: Thanks to the Scroll Lock comment. Just press Scroll Lock key on my keyboard to toggle between using the arrow keys for moving between cells or moving the scroll bars.

Actually not a bad feature, just something I never thought of. In my 30+ years of using computers I have never ever used the Scroll Lock key for anything before. Don't know what this means for people on Macs and modern keyboard that may not have this key.

edit flag offensive delete link more

Comments

I was also confused by this behavior for several days until I remembered from 1982 or so that this is the "scroll lock" behavior of the original IBM PC, but few editors or other programs ever used the feature.

Laptop keyboards don't have the Scroll Lock status light (see above where this is a rarely used feature) like full-size desktop keyboards have always had. Perhaps adding a "Scroll Lock On" status on the bottom line when it's active would help

benbradley gravatar imagebenbradley ( 2017-06-21 03:37:33 +0200 )edit
1

answered 2017-02-26 13:54:12 +0200

linuxovios gravatar image

updated 2017-02-26 14:07:45 +0200

This must be a bug in 5.3.0.3.

Same behavior happens to me also. The problem exists when I change to greek keyboard.

When I change to english keyboard, arrow keys behave properly again.

edit: I FOUND SOLUTION

I use linux mint and by default I was changing keyboard layout with alt+shift. So when I noticed that changing to greek layout caused the problematic behavior of arrow keys, I went to my OS (linux mint) keyboard settings . "switching to another layout" option was not enabled for a key combination (even though somehow my os could change keyb layout as I already mentioned). So I checked the key combination I preferred (alt+shift) and then went back to libre calc. Now the arrow keys work as they should, no matter what keyb layout I am using.

I hope that helps.

edit flag offensive delete link more
1

answered 2017-04-07 07:54:03 +0200

kostas vekrakis gravatar image

I had the same problem and i found the solution (at least for kde linux). In the advanced keyboard settings there is an option "Use keyboard LED to show alternative layout". By default, Scroll lock is checked. I unchecked it and the problem was fixed.

edit flag offensive delete link more
1

answered 2017-10-24 15:18:58 +0200

Alexey R. gravatar image

I found another way. Here is configuration item in Ubuntu for keyboard settings to stop this. Run mate-keyboard-properties or other keyboard preferences application. Select Layout tab and then press Options button. There is item > "Use keyboard LED to show alternative layout". Solution: off all LED.

Now when you will change layout the LED will not On. I had problem with Scroll Lock and Calc scroll list instead change position with arrow keys.

BTW: can't upload screen... not enough karma Be happy :)

edit flag offensive delete link more
0

answered 2017-02-27 17:35:33 +0200

Zeca gravatar image

I have no problem. I am using LO 5.3.0.3 and an english keyboard Win7 32 bit.

edit flag offensive delete link more
0

answered 2017-09-23 18:03:43 +0200

Elijah gravatar image

For those of us without a Scroll-Lock key: In windows 10 you can use the "On Screen Keyboard"

edit flag offensive delete link more
0

answered 2017-05-31 11:23:33 +0200

https://ask.libreoffice.org/en/questi...

https://ask.libreoffice.org/en/questi...

The reason is this RFE: tdf#46200, that was fixed for 5.3. So, this is a new feature, and works as intended. It happens to interfere with some systems' ScrollLock that indicates unrelated things like keyboard layout. This isn't configurable ATM.

You may see that e.g. here this feature was asked for.

edit flag offensive delete link more
0

answered 2017-07-09 01:30:27 +0200

I am having the same problem afterinsatlling : Version: 5.3.4.2 (x64) Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; Locale: en-US (en_US); Calc: group

Using the SCR LX key will solve the problem, but the manufacturer of the keyboard I have uses that key to togle the back light on and off. Back lights on, arrows don't function properly. Back lights off, arrows work but I can't read the keyboard.

edit flag offensive delete link more
0

answered 2017-02-22 20:18:47 +0200

normann gravatar image

I give up. Goin' back to LibreOffice 5.2(.5.1) that doesn't have this behavior.

edit flag offensive delete link more
-1

answered 2017-05-31 10:03:51 +0200

harkunglo gravatar image

Present in LO 5.3.3.2 (x64)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2017-02-14 21:41:44 +0200

Seen: 8,039 times

Last updated: Oct 24 '17