Ask Your Question
0

The connection to the data source "Database" could not be established. The driver class " could not be loaded

asked 2017-02-25 08:14:50 +0200

millieroo gravatar image

I received this error immediately after upgrading to LibraOffice 5.2.5.

The connection to the data source "Database" could not be established. The driver class " could not be loaded

Previously, that is minutes immediately before the upgrade, I had no issues. I am a newbie user, and was only using the delivered database function, not connecting to any external database.

Fortunately I backed up, but now I have no idea how to get my database working again. How do I 'backwards upgrade'?

I'm on a Mac 10.12.3

thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-02-26 18:57:27 +0200

Ratslinger gravatar image

I have hesitated to answer this question because of limited Mac knowledge.

Your message is typical of not having Java installed/enabled. I believe in Mac it is under Preferences then LibreOffice->Advanced. Use a Java runtime environment should be checked. Then if Java is installed, make sure one is chosen from the list (screenshot from Linux):

image description

Now, if there isn't any Java choice you may have upgraded LO from v4.x and you may have had JRE installed. You now need to install JDK from Oracle (latest version should work).

edit flag offensive delete link more
0

answered 2019-06-23 08:23:49 +0200

Ricollect gravatar image

I have the same issue.

I went to the Preferences mentioned, but Java options are greyed out.

Part of the greyed out text says, "Java runtime environments (JRE) already installed."

I'm just starting to try Base, and can open the database fine, but when i choose Tables (so i can create some), i get this error.

??

edit flag offensive delete link more

Comments

@Ricollect,

Answers are to be a response to original question. Yours is a question. Please either use add a comment or ask as a new question with all relative information - specific LO version, OS, actual problem etc.

Also please see this Wiki -> How to install Java (JRE/JDK) so that LibreOffice could use it?

Ratslinger gravatar imageRatslinger ( 2019-06-23 17:08:29 +0200 )edit

My apologies. I will check this in future.

Meantime, thanks for your answer and the work you and other volunteers do.

Ricollect gravatar imageRicollect ( 2019-06-24 00:31:45 +0200 )edit

I looked at the Wiki, which says that mac users like me need jdk, not jre. For anyone who comes across this page, the download link for jdk now appears to be https://www.oracle.com/technetwork/ja...

Ricollect gravatar imageRicollect ( 2019-06-24 00:43:54 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-25 08:14:50 +0200

Seen: 2,024 times

Last updated: Jun 23