Ask Your Question

Opening .rtf [closed]

asked 2017-03-21 11:20:59 +0200

Whatsisname gravatar image

updated 2020-09-28 16:28:13 +0200

Alex Kemp gravatar image

Rich text documents are still being opened in LO calc spreadsheet and do not display properly. The "open with" work around only offers calc and further open with LO writer produces a file opening failure. Are there any moves afoot in Libre to address this difficulty, or can this comment be used to raise the issue?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-09-28 16:29:20.040952


Never met such a problem. It's difficult to say anything without seeing a test document which opens as you describe, without details about your OS and LO versions.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-21 11:42:13 +0200 )edit

Whoops! Meant to include; Windows 10 Home Version 1607. Libre Office Version: Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22 CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Locale: en-GB (en_GB); Calc: group. I notice the update to LO 5.3, has this cured the problem?

Whatsisname gravatar imageWhatsisname ( 2017-03-21 13:10:19 +0200 )edit

As I mentioned, I've newer met such problem; so I cannot tell if it's fixed. I personally suspect either OS association problem, or a corrupted profile. But who knows. A file to test would possibly help.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-21 13:53:32 +0200 )edit

Having the same problem also. I've tried to different programs. Whizfolders and UV outliner. When LIbre Writer opens them, they are inside of a table. However, when I open an rtf file that was created on a mac by Omni Outliner. Liber imports the file perfectly. It also maintains the hierarchy of the outline. Using Thinkpade460 on windows 10 with 4meg ram.

eja gravatar imageeja ( 2017-09-21 16:34:58 +0200 )edit

Well, I just went back and tried creating rtf files with Whizfolders and UV outliner once again. Now all seems to be working. Go figure. I spent about 30 minutes doing the same thing yesterday and had no success. I'll see how it goes next time.

eja gravatar imageeja ( 2017-09-21 16:42:15 +0200 )edit

2 Answers

Sort by » oldest newest most voted

answered 2017-03-23 18:44:39 +0200

JohnHa gravatar image

updated 2017-03-27 11:42:05 +0200

rtf files are word processor files, not spreadsheets. Open them with Writer.

rtf files can also be opened with Notepad in which case the formatting control characters are shown.

Rich text documents are still being opened in LO calc spreadsheet

You have probably associated the .rtf file with scalc.exe so clicking it opens it with Calc. Associate .rtf files with swriter.exe or soffice.exe.

edit flag offensive delete link more

answered 2017-03-27 10:15:38 +0200

Whatsisname gravatar image

Please find the list below from Software that will open, convert or fix RTF files Windows Free File Viewer Verified Doxillion Verified Microsoft Office User Submitted Microsoft Office XP User Submitted Calc User Submitted

I am quite aware that .rtf extensions are Microsoft developments. We once had a problem sending emails direct from within Libre using Windows Live Mail so I am also aware that on occasion Libre lags Microsoft's goal moving.

How do I raise this issue with Libre? Don't get me wrong, as far as I am concerned Libre is one of the modern wonders of the world!

edit flag offensive delete link more


I repeat again: on most systems, there's no problems that you describe: I am not aware of any system that would open a correct RTF as a spreadsheet; they are always opened in Writer; so I don't see your "still" as if it continues. So, there are two possibilities:

  1. You have some RTFs that are strange (maybe they aren't actually RTFs? Maybe they aren't proper RTFs? Maybe they have something we don't support yet?)
  2. You have some system misconfiguration

You may file a bug at Bugzilla

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-27 10:28:35 +0200 )edit

If you start your question with "Rich text documents are still being opened..." (as if this is a long-standing and known issue), then back your statement with some evidence that this problem was encountered before, like an existing bug report, or a forum discussion link...

Also: you are not answering your own question with the "answer" you posted. So, please don't post your comments as answer. Instead, use "Add comment" for that.

Mike Kaganski gravatar imageMike Kaganski ( 2017-03-27 10:44:55 +0200 )edit

Question Tools



Asked: 2017-03-21 11:20:59 +0200

Seen: 4,154 times

Last updated: Mar 27 '17