Ask Your Question
1

line graphic

asked 2017-03-21 20:02:43 +0200

kgd gravatar image

I make my schematics using a line editor box editor tool. The files are simple .TXT files. When I open the file in Libre Writer I get: 1 first graphic is what I don't want. 2. Second graphic is after search/replacing all of the box characters. I don't see a way to have it open and display it properly. Of course once I open "import" it, after changing the characters, I save it as an ODT. I would show it graphically, but I need more than 3 points to upload files? This is wrong... ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³ ARDUINO MEGA 2560 ³ ³ OR EQIVALENT 74HC4050 DB9 CONNECTOR ³ ³ (CONTROL) 5V0 (LEVEL SHIFT) 3V3 ³ ³ ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿ ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿ ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³ ³14 9 ³ ³ 10 1 ³ ³ ³ ³ ³ TX3 ÃÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ´ 4A 4Y ÃÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ´ TX (TO RLY/UUT)ÃÄÄÄ> ³ ³ ³ ³15 12 ³ (ON....) ³ 11 2 ³ ³ ³ ³ ³ RX3 ÃÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ´ 5Y 5A ÃÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ´ RX (TO RLY/UUT)ÃÄÄÄ< ³ ³ ³ ³20 1 ³ (PROTO.) ³ 1 3 ³ ³ ³ ³ ³ 3V3 ÃÄÄÄÄÂÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ´ VCC 3V3 ÃÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ´ 3V3 (TO PCF8574)ÃÄÄÄ> ³

This is what I want it to look like when it opens the file. Keep the characters. ┌──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┐ │ │ │ │ │ │ │ │ │ │ │ │ │ ARDUINO MEGA 2560 │ │ OR EQUIVALENT 74HC4050 DB9 CONNECTOR │ │ (CONTROL) 5V0 (LEVEL SHIFT) 3V3 │ │ ┌─────────────────┐ ┌─────────────────┐ ┌─────────────────┐ │ │ │ │ │ │ │ │ │ │ │ │14 9 │ │ 10 1 │ │ │ │ │ TX3 ├─────────────────────────────┤ 4A 4Y ├─────────────────────────────┤ TX (TO RLY/UUT)├───> │ │ │ │15 12 │ (ON....) │ 11 2 │ │ │ │ │ RX3 ├─────────────────────────────┤ 5Y 5A ├─────────────────────────────┤ RX (TO RLY/UUT)├───< │ │ │ │20 1 │ (PROTO.) │ 1 3 │ │ │ │ │ 3V3 ├────┬────────────────────────┤ VCC 3V3 ├─────────────────────────────┤ 3V3 (TO PCF8574)├───> │ │ │ │A3 │ 8 │ (SHIELD) │ 8 │ │ │ │ │ SENSE 3V3 ├────┘ ┌─────────────┤ GND │ ┌────────────────────┤ SDA (I2C DEVS) ├───<> ALL │ │ │ │ │ │ │ │ 9 │ │ │ │ │ GND ├───────────────┘ └─────────────────┘ │ ┌─────────────────┤ SCL (I2C DEVS) ├───> TO PAGE 2,3,4 │ │ │ │ │ │ │ │ │

edit retag flag offensive close merge delete

Comments

It's better to upload a sample file. It is possible that you use characters that aren't available in the default font for Writer documents.

floris v gravatar imagefloris v ( 2017-03-21 20:29:19 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2017-03-21 22:17:15 +0200

Regina gravatar image

You are using a wrong encoding. When you use File > Open, you get a drop-down list on the right side, where you can choose the import filter. There you select Text - Choose Encoding (*.txt). It seems, that your text has a DOS encoding of code page 850 or 437, likely from the group Western Europe. To be sure I would need the original file. Please report back, whether choosing such filter works for you.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-21 20:02:43 +0200

Seen: 25 times

Last updated: Mar 21 '17