Ask Your Question
1

"Write-protected content cannot be changed" - but I'd like to...

asked 2017-04-05 12:52:16 +0200

putt1ck gravatar image

Using a pro-forma legal document with a number of areas that look like fields (but don't seem to be) where you are supposed to fill out to complete the doc. Some of the sections are not relevant to my scenario so try to delete them and get popup message:

"Write-protected content cannot be changed."

These are not cells that can be unprotected, and not fields as such (no "Fields" option if you right-click, and nothing happens to them if you set View -> Field Names.

The original document was a Word .doc, possibly 2003 format. It has been saved as an odt. If you cut and paste a bit of the doc with one of these entry fields into a new doc it exhibits the same behaviour. Is there

(a) anyway to turn this off?

(b) anyway to reproduce similar behaviour without using a table cell?

NB Version: 5.3.1.2 on openSUSE

edit retag flag offensive close merge delete

Comments

hey..have you figured this thing out?? i copy pasted content from knowhownonprofit.org then it was saved in some word doc and now whenever i try to do anything to this content get the same error you get..

hivy gravatar imagehivy ( 2017-07-28 12:28:22 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2017-04-05 17:50:39 +0200

edit flag offensive delete link more

Comments

That sounds very similar, although AFAICT these words aren't fields in LO's understanding, or - if I use the equivalent function in LO, Insert -> Field -> More Fields -> Input Field the result looks very similar but (a) if you right click "Fields" is an item on the context menu and (b) they are not write protected. Hopefully your patch will fix the issue - in the meantime I had discovered the workaround of selecting the object plus a few chars either side and deleting or overwriting from there.

putt1ck gravatar imageputt1ck ( 2017-04-16 07:40:34 +0200 )edit

The discussed patch doesn't deal with LibreOffice fields; it deals with legacy MS Word fields that LO supports for compatibility. There's no UI to insert these in LO. That's what both me and you are talking about.

Mike Kaganski gravatar imageMike Kaganski ( 2017-04-16 08:04:29 +0200 )edit
1

answered 2017-12-04 10:53:21 +0200

quazgar gravatar image

I solved my problem with protected forms by unsetting an option in the Options dialog:

Tools > Options ... > LibreOffice Writer > Compatibility > Remove the tick mark from the " Protect form " line.

edit flag offensive delete link more

Comments

1

This is the only answer that worked for me.

pillarsdotnet gravatar imagepillarsdotnet ( 2018-04-16 19:48:15 +0200 )edit

Didn't work in my case. However: In LibreOffice 6.1.5.2, if you right-click on the immutable field or whatever it is, then select "Edit Section" in the popup menu, then unmark "Write Protection" [Protected], you will be able to edit/delete the nastiness.

Jacques Guddebuer gravatar imageJacques Guddebuer ( 2019-03-13 22:28:53 +0200 )edit
0

answered 2017-04-05 17:46:13 +0200

peterwt gravatar image

Do these areas have a light grey outline? If so they are Sections and you can confirm this by using the Navigator (F5) where there will be Sections listed with names. Sections can be protected and if you attempt to modify a protected section you will get "Write-protected content cannot be changed." "No modifications will be accepted." Provided a password has not been used to protect these sections you can un-protect them so they can be deleted. Use Format > Sections and uncheck the write protection box.

edit flag offensive delete link more

Comments

No, they're not sections (but the words are on a light grey background, and look similar to Fields)

putt1ck gravatar imageputt1ck ( 2017-04-16 07:26:45 +0200 )edit
0

answered 2019-04-04 13:40:01 +0200

jkirk gravatar image

I was able to delete the field by un-setting the following option:

Tools > Options > LibreOffice Writer > Formatting Aids > Remove tick from Protecting Areas / Enable cursor.

LibreOffice Writer 5.2.7

Found this solution here.

edit flag offensive delete link more

Comments

This worked for me. THANK YOU!!

LibrenotLibra gravatar imageLibrenotLibra ( 2019-07-12 17:57:51 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-04-05 12:52:16 +0200

Seen: 19,441 times

Last updated: Apr 04