Ask Your Question
0

Formulas not displaying properly [closed]

asked 2013-01-02 18:33:17 +0200

Enkel gravatar image

I have a cell in a spreadsheet (say J2) which contains a formula (say =if(i2=4,"YES", "NO")). The trouble is that although I want J2 to display either "YES" or "NO" J2 actually displays "IF(I2=4,"YES","NO")" How do I make J2 display what I want it to, please?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 11:32:19.760212

7 Answers

Sort by » oldest newest most voted
1

answered 2013-01-03 00:57:04 +0200

m.a.riosv gravatar image

Depending on your language, the separator should be semicolon instead of comma. =if(i2=4;"YES";"NO")

edit flag offensive delete link more
2

answered 2013-01-03 19:11:02 +0200

Enkel gravatar image

Manov, you've got it! The problem was with the commas and semi-colons! If I put a semi-colon separator it doesn't work, but with commas it does work. Don't know why, I'm working in English and my help file shows semi-colons, but the expression definitely needs commas! Is this a bug?

Regards

edit flag offensive delete link more
0

answered 2013-01-04 00:23:43 +0200

m.a.riosv gravatar image

Maybe you have set the language to Englis-US. Take a look in Menu/Options/Language settings/language and also in Menu/Options/LibreOffice calc/formulas where the separator can be reassigned.

edit flag offensive delete link more
0

answered 2013-01-02 21:03:36 +0200

m.a.riosv gravatar image

Verify the option in Menu/Tools/Options/LibreOffice calc/view - Display: formulas it is not marked.
If not, maybe the cell is formatted as text, if so, every thing you enter is treated as text, not as formula or number. Set the format to default with Ctrl+M, if this not work, open the Styles and formatting box, and apply the default format by double click it with the cell selected.

edit flag offensive delete link more
0

answered 2013-01-03 17:42:16 +0200

Enkel gravatar image

Sorry about my slip of the keyboard. Yes, when I put the formula in the spreadsheet I used semi-colons, but they mysteriously metamorphosed into commas in my posting. So, regrettably, that's not the problem!

Regards

Enkel

edit flag offensive delete link more
0

answered 2013-01-02 23:39:50 +0200

Enkel gravatar image

Thanks. manov, but ...
Tools/Options/LibreOffice Calc/View Display formulas is not marked Selected Cell and pressed Ctrl-M. No change Styles and Formatting, Default already marked but selected it anyway - no change. Any further thoughts?

Enkel

edit flag offensive delete link more
0

answered 2014-01-06 04:46:39 +0200

wsanders gravatar image

updated 2014-01-06 04:51:37 +0200

I have all spell checking disabled, and converting semicolons into commas in formulas when typed seems to be the default behavior for me (in US English) as well - both in Version: 4.1.4.2, Build ID: 4.1.4.2-2.fc20, in Fedora Core 20 amd 4.1.4.2 on MacOS Mountain Lion.

The formulas seem to behave normally.

Perhaps the use of semicolons is deprecated in English? This would make the use of commas in functions conform to the function syntax in Excel (spits on ground and crosses self to avoid the evil eye) and maybe some other spreadsheet SW and would make it easier for LO noobs to get started.

Although how would someone type something like SUM(0,4;0,6) in other spreadsheet SW in regions where commas are used as decimal points?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-01-02 18:33:17 +0200

Seen: 1,610 times

Last updated: Jan 06 '14