Ask Your Question
0

LibreOffice doesn't recognize portuguese special characters while typing

asked 2017-06-13 17:19:30 +0100

pliniohcc gravatar image

Hello!

When I'm typing something at LibreOffice (doesn't matter if it's Writer or Calc), the portuguese special characters like "á, é, ã, ç" comes up like this "á, é, ã, ç".

I'm using LibreOffice 5.3 on Manjaro Linux with en_US.UTF-8 coding and my keyboard is Brazilian Portuguese (pt-br). I've already tried LO 5.2, but when I typed that characters they simple don't appear at all.

Is there a way to fix this?

Thanks!

edit retag flag offensive close merge delete

Comments

Is your keyboard defined as Brazilian Portuguese with extended keys to the Linux system? It looks as if your Unicode-8 is being treated as US-ASCII which shows the single Unicode character as three US-ASCII. You often see this if you copy an Unicode character and paste it to US-ASCII document.

You should be able to insert a Portuguese character into a LibO document using INSERT > SPECIAL CHARACTER which will bypass your keyboard settings.

petermau gravatar imagepetermau ( 2017-06-13 18:56:59 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-09-21 23:05:11 +0100

I have the same issue: Manjaro KDE + LibreOffice 5.3.6-1 with a french physical keyboard. Typing the french special characters works in all applications except Libre Office. In LO when I type é it is printed as é, è is printed as è, ç is ç and so on.

I've tried multiple French keyboard layouts: Default, French(AZERTY), French (no dead keys), but the issue persists

Locale is set to:LANG=en_US.UTF-8

When I run libreoffice from terminal, I see 2 messages:

I18N: Operating system doesn't support locale ""                      
I18N: Operating system doesn't support locale "en_US"

Any ideas ?

edit flag offensive delete link more
0

answered 2017-09-22 18:49:29 +0100

petermau gravatar image

I came across this reference with regards to a Ubuntu problem with language locale https://askubuntu.com/questions/50118..., There appears to be a Ubuntu-Linux problem changing from LANG=en_US.UTF-8 to other languages. This may be of some help. A possible by pass is to go via LANG=en_GB.UTF-8!!

The problem does seem to be related to the fact that your system is not passing valid Unicode characters to LibreOffice. I do not have this same problem on my Linux-Mint system with a LANG=en_GB.UTF-8 setting directly entering characters from the keyboard using English-GB, Englis-USA, French azerty and Swiss French/German. I believe it is not a LibO problem

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-13 17:19:30 +0100

Seen: 600 times

Last updated: Sep 22 '17