Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

What is wrong with libre office base?

Today I wanted to open a database created in 2015. It opened but I couldn't acces any tables the error message being The connection to the data source "VideoDatenbank" could not be established. And a second error said SQL Status: HY000 The connection could not be established. The database was created by a newer version of LibreOffice.

So I created a new database, saved it and when I try to open I get the same errors. What the heck is wrong here? Is base unusable? I am on Linux Mint 18 and libre office Version: 5.1.6.2 Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2 CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; Locale: en-US (en_US.UTF-8); Calc: group

Help is greatly appreciated

What is wrong with libre office base?

Today I wanted to open a database created in 2015. It opened but I couldn't acces access any tables the error message being The connection to the data source "VideoDatenbank" could not be established. And a second error said SQL Status: HY000 being:

The connection could not be established. The database was created by a newer version of LibreOffice.LibreOffice. details revealed SQL Status: HY000

So I created a new database, saved it and when I try to open I get the same errors. What the heck is wrong here? Is base unusable? errors.

I am on Linux Mint 18 and libre office Version: 5.1.6.2 Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2 CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; Locale: en-US (en_US.UTF-8); Calc: group

Help is greatly appreciated

Edit 2018-1-13

When I examine the .odb file using an archive utility and open /database/properties with gedit I get:

'#'HSQL Database Engine 2.3.0

'#'Tue Dec 05 08:33:28 CET 2017

version=2.3.0

modified=yes

When I create a new database with my current libre-office base version which is Version: 5.1.6.2, the properties file has:

'#'HSQL Database Engine 1.8.0.10 '#'Fri Jan 12 16:41:32 CET 2018 hsqldb.script_format=0 runtime.gc_interval=0 sql.enforce_strict_size=true hsqldb.cache_size_scale=8 readonly=false hsqldb.nio_data_file=false hsqldb.cache_scale=13 version=1.8.0 hsqldb.default_table_type=cached hsqldb.cache_file_scale=1 hsqldb.lock_file=true hsqldb.log_size=10 modified=yes hsqldb.cache_version=1.7.0 hsqldb.original_version=1.8.0 hsqldb.compatible_version=1.8.0"

So obviously the error message is correct but how it got that way I have no idea. Since the first post I have reproduced this with several attempts.

Is there a way to change my setup in a way that I can open both types of databases?

What is wrong with libre office base?

Today I wanted to open a database created in 2015. It opened but I couldn't access any tables the error message being:

The connection could not be established. The database was created by a newer version of LibreOffice. details revealed SQL Status: HY000

So I created a new database, saved it and when I try to open I get the same errors.

I am on Linux Mint 18 and libre office Version: 5.1.6.2 Build ID: 1:5.1.6~rc2-0ubuntu1~xenial2 CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; Locale: en-US (en_US.UTF-8); Calc: group

Help is greatly appreciated

Edit 2018-1-13

When I examine the .odb file using an archive utility and open /database/properties with gedit I get:

'#'HSQL Database Engine 2.3.0

'#'Tue Dec 05 08:33:28 CET 2017

version=2.3.0

modified=yes

When I create a new database with my current libre-office base version which is Version: 5.1.6.2, the properties file has:

'#'HSQL Database Engine 1.8.0.10 '#'Fri Jan 12 16:41:32 CET 2018 hsqldb.script_format=0 runtime.gc_interval=0 sql.enforce_strict_size=true hsqldb.cache_size_scale=8 readonly=false hsqldb.nio_data_file=false hsqldb.cache_scale=13 version=1.8.0 hsqldb.default_table_type=cached hsqldb.cache_file_scale=1 hsqldb.lock_file=true hsqldb.log_size=10 modified=yes hsqldb.cache_version=1.7.0 hsqldb.original_version=1.8.0 hsqldb.compatible_version=1.8.0"

So obviously the error message is correct but how it got that way I have no idea. Since the first post I have reproduced this with several attempts. different .odb files created around the same time the original was created.

Is there a way to change my setup in a way that I can open both types of databases?