Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to reset table of contents settings for individual document

I am trying to fully reset the Table Of Contents settings for an individual document. How do I do that please?

I note the Reset options on individual panes as I edit a ToC but those do not seem to fully reset it, or if they do it requires individually resetting everyting and there are quite a lot of tabs and options to work through.

Thanks in advance for anyone tryng to assist with this. The issue itself that prompts me to write this question is that Tables of Contents are indexing their own content. So if I do a ToC of the whole doc and a ToC to say level 3 the level 3 ToC is picking up some of the internal ToC and indexinfg that. If I then create another ToC to level 3 and leave that as editable in an attempt to troubleshoot that indexes the first level 3 ToC.

My profiles location does not contain any templates folder, so as far as I am aware no custom template is in use. I did edit the ToC settings to add a coloured background to some of the headings, but that has not caused issues with other files. Other documents on the same computer account do not seem to display this unexpected behaviour. I will attach a screenshot of the ToC s 1st ToC 2nd ToC including indexing of the first ToC

An answer relating to WINDOWS will probably suffice as that is probably more popular and will no doubt help me resolve this issue. I am currently using Libre Writer v5.2.7.2 on Linux (Debian) but also read, write and edit Libre Writer files on Windows 7 & 10 and even on Android using the Viewer App experimental feature.

This is a rather trivial issue on the current document, but I have several documents that run to hundreds of pages and I do not want this issue to start affecting them, something that could potentially occur If I am unable to resolve and understand this problem.

How to reset table of contents settings for individual document

I am trying to fully reset the Table Of Contents settings for an individual document. How do I do that please?

Edit about an hour after posting. I am revising to use a shorter file almost a reduced test case. I will leave the original screenshots but add new ones for a shorter file which I will then attach.

I note the Reset options on individual panes as I edit a ToC but those do not seem to fully reset it, or if they do it requires individually resetting everyting and there are quite a lot of tabs and options to work through.

Thanks in advance for anyone tryng to assist with this. The issue itself that prompts me to write this question is that Tables of Contents are indexing their own content. So if I do a ToC of the whole doc and a ToC to say level 3 the level 3 ToC is picking up some of the internal ToC and indexinfg that. If I then create another ToC to level 3 and leave that as editable in an attempt to troubleshoot that indexes the first level 3 ToC.

My profiles location does not contain any templates folder, so as far as I am aware no custom template is in use. I did edit the ToC settings to add a coloured background to some of the headings, but that has not caused issues with other files. Other documents on the same computer account do not seem to display this unexpected behaviour. I will attach a screenshot of the ToC s s

Revised screenshots relating to attached test file generating unexpected results This ToC includes index of its own content This Full ToC also indexes from within Note in these screenshots the numbers to the left are ones I have added by way of explanation/confirmation of header levels. Any numbers to the right are generated by the Table Of Contents. Hopefully I can attach the short test file I used.example-toc-issue.odt

Original Screenshots these may be ignored 1st ToC 2nd ToC including indexing of the first ToC

An answer relating to WINDOWS will probably suffice as that is probably more popular and will no doubt help me resolve this issue. I am currently using Libre Writer v5.2.7.2 on Linux (Debian) but also read, write and edit Libre Writer files on Windows 7 & 10 and even on Android using the Viewer App experimental feature.

This is a rather trivial issue on the current document, but I have several documents that run to hundreds of pages and I do not want this issue to start affecting them, something that could potentially occur If I am unable to resolve and understand this problem.

How to reset table of contents settings for individual document

I am trying to fully reset the Table Of Contents settings for an individual document. How do I do that please?

Edit about an hour after posting. I am revising to use a shorter file almost a reduced test case. I will leave the original screenshots but add new ones for a shorter file which I will then attach. 2nd Edit Using the file I attached I have opened that in another account in Writer and deleted the original ToC and added fresh ones. Those look as expected. They do not try to index themselves. I have added a screenshot of expected results.

I note the Reset options on individual panes as I edit a ToC but those do not seem to fully reset it, or if they do it requires individually resetting everyting everything and there are quite a lot of tabs and options to work through.

Thanks in advance for anyone tryng to assist with this. The issue itself that prompts me to write this question is that Tables of Contents are indexing their own content. So if I do a ToC of the whole doc and a ToC to say level 3 the level 3 ToC is picking up some of the internal ToC and indexinfg indexing that. If I then create another ToC to level 3 and leave that as editable in an attempt to troubleshoot that indexes the first level 3 ToC.

My profiles location does not contain any templates folder, so as far as I am aware no custom template is in use. I did edit the ToC settings to add a coloured background to some of the headings, but that has not caused issues with other files. Other documents on the same computer account do not seem to display this unexpected behaviour. I will attach a screenshot of the ToC s

Revised screenshots relating to attached test file generating unexpected results This ToC includes index of its own content This Full ToC also indexes from within Note in these screenshots the numbers to the left are ones I have added by way of explanation/confirmation of header levels. Any numbers to the right are generated by the Table Of Contents. Hopefully I can attach the short test file I used.example-toc-issue.odt

EXPECTED result. Test file with new Table of Contents same-example-new-toc

Original Screenshots these may be ignored 1st ToC 2nd ToC including indexing of the first ToC

An answer relating to WINDOWS will probably suffice as that is probably more popular and will no doubt help me resolve this issue. I am currently using Libre Writer v5.2.7.2 on Linux (Debian) but also read, write and edit Libre Writer files on Windows 7 & 10 and even on Android using the Viewer App experimental feature.

This is a rather trivial issue on the current document, but I have several documents that run to hundreds of pages and I do not want this issue to start affecting them, something that could potentially occur If I am unable to resolve and understand this problem.