Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

LO Base is not saving the field formatting when editing a table

Hello,

I have a Pattern Field Mask using the Form Editor, in a little HSQLDB. I'm trying to avoid typos in an important field (the geographic position of the data taken). So I used the following mask:

NNLNN as the Edit Mask

"GG:DD" as the Literal Mask.

Let say I named the field as LAT. Then, in the Table editor, in the corresponding LAT field format example, I choose 2 leading zeros and 2 decimal places... so the data should be stored as: 09.45

The format field in Table Editor

Everything works OK during a session, but when I close LO, and I start the following day, the LAT field format example is lost to the default settings, so the data is stored as 9.45 (note there isn't a leading zero anymore). And this cause display problems in the Form... say instead of visualizing the data as 09.45, all I see is 94.5D

The last D came from the literal mask.

So, what I need is a way to set the LAT format field in a way it doesn't change between sessions.

Help is greatly appreciated.

LO Base is not saving the field formatting when editing a table

Hello,

I have a Pattern Field Mask using the Form Editor, in a little HSQLDB. I'm trying to avoid typos in an important field (the geographic position of the data taken). So I used the following mask:

NNLNN as the Edit Mask

"GG:DD" as the Literal Mask.

Let say I named the field as LAT. Then, in the Table editor, in the corresponding LAT field format example, I choose 2 leading zeros and 2 decimal places... so the data should be stored as: 09.45

The format field in Table Editor

Everything works OK during a session, but when I close LO, and I start the following day, the LAT field format example is lost to the default settings, so the data is stored as 9.45 (note there isn't a leading zero anymore). And this cause display problems in the Form... say instead of visualizing the data as 09.45, all I see is 94.5D

The last D came from the literal mask.

So, what I need is a way to set the LAT format field in a way it doesn't change between sessions.

Help is greatly appreciated.