Ask Your Question

simon's profile - activity

2017-11-17 06:32:19 +0200 received badge  Necromancer (source)
2017-10-27 05:07:39 +0200 answered a question Libre Calc, Remove email hyper link

A straightforward solution for removing hyperlinks is select the cells containing hyperlinks Click on Format > Clea

2017-10-27 05:06:59 +0200 answered a question How to disable email link in calc

A more straightforward solution for removing hyperlinks is select the cells containing hyperlinks Click on Format >

2016-07-07 23:46:54 +0200 commented answer Will Writer ever provide MS Word style outlining (not navigator)?

@Thing -- I agree entirely with you comment; it is almost totally irrelevant to the issue at hand, of course, but I agree all the same.

2015-11-03 21:13:01 +0200 received badge  Enlightened (source)
2015-09-15 20:54:07 +0200 received badge  Famous Question (source)
2014-11-30 22:01:34 +0200 received badge  Notable Question (source)
2014-11-30 18:46:03 +0200 received badge  Commentator
2014-11-30 18:46:03 +0200 commented answer show/hide the side panel

Thanks for your answer @Rugslug -- this is not the "sidebar" I'm talking about, unfortunately (which is why I went to the trouble of including a screenshot). I should have mentioned that I had already used the method you describe. I suppose I've just hit a limitation of LO.

2014-11-30 16:13:09 +0200 received badge  Popular Question (source)
2014-11-18 20:51:46 +0200 asked a question show/hide the side panel

Hi -- I use the side panel in LO Writer to display the Navigator and the "Styles and Formatting window" (see the attached screenshot). By clicking on the handle, I can show/hide the whole panel (not simply undock the windows, or show/hide the individual components).

Is there any way to do this with a keyboard shortcut? I am familiar with PyUno and can write an python script to do this programmatically if a relevant api is exposed.

I would be grateful for any help with this! Thanks!

screenshot

2013-09-20 14:46:41 +0200 received badge  Critic (source)
2013-09-20 14:46:21 +0200 received badge  Supporter (source)
2013-07-16 18:55:36 +0200 received badge  Famous Question (source)
2013-07-10 21:22:34 +0200 commented question problem with full-width (asian) punctuation

Thanks – I don't entirely follow what you mean by "fd0#123456": ought that to be automatically marked-up? because I can't seem to get that to work! Cheers :)

2013-07-10 19:45:48 +0200 commented answer Joining subsequent paragraphs with same style

Thanks -- updated :)

2013-07-10 16:06:14 +0200 received badge  Good Answer (source)
2013-07-10 15:17:03 +0200 received badge  Nice Answer (source)
2013-07-10 00:51:45 +0200 commented answer Joining subsequent paragraphs with same style

It seems I don't have enough karma to post a link to the bug report, sorry -- it's #53360...

2013-07-10 00:50:47 +0200 answered a question Joining subsequent paragraphs with same style

If you're sure you want to do it that way, then it ought to be possible, but in fact there may be another (better) way to go about what you want to achieve.

If you select the paragraphs in question, and use Format > Paragraph, then under Indents & Spacing you'll find an option called (in English!) Don't add space between paragraphs of the same style. If I've understood you correctly, this should give you the result you're looking for.

Note: there's a long-standing bug which means that this option doesn't appear when establishing or modifying a paragraph style, but there are ways to work around this.

fd0#53360

2013-07-09 19:47:45 +0200 received badge  Notable Question (source)
2013-07-09 19:47:45 +0200 received badge  Popular Question (source)
2013-07-06 01:24:58 +0200 commented answer problem with full-width (asian) punctuation

For what it's worth, I'm pretty sure this has nothing to do with the input method: the situation is exactly the same whether I use iBus, SCIM, or if I simply paste the 漢字 as plain text with the SCIM or iBus daemon not even running.

2013-07-02 09:23:13 +0200 received badge  Teacher (source)
2013-07-02 01:42:57 +0200 answered a question print directly only one sheet PDF Calc

You can add an Export to PDF button to the toolbar (as opposed the Export directly to PDF button that is there by default), which will launch the settings dialogue, if that will do?

Failing that, all I can think of would be to create a Macro which would call Export to PDF with your custom settings, and assign that to a toolbar button.

2013-07-02 01:30:47 +0200 commented answer problem with full-width (asian) punctuation

I'm using a Debian-based distro, with LO 4.0.4.2. I use SCIM for choice, but the situation is no different on a second machine which uses iBus (each with Chewing for Chinese and Anthy for Japanese). Font-wise, the same issue exists regardless of the font, of course – right now I'm using PMingLiU for the 漢字 and Gentium for the Latin-based stuff.

2013-07-02 01:30:20 +0200 commented answer problem with full-width (asian) punctuation

The “full-width space effect” is actually caused by the fact that the opening quotation is rendered according to the “Asian text font” setting (in this case, PMingLiU at 10.5pt.). There is no full-width space U+3000 anywhere.

2013-07-02 01:27:41 +0200 commented answer problem with full-width (asian) punctuation

I certainly am switching typing modes after typing 日 and before typing the space and then “. I take the point about U+002C being a neutral character (although it strikes me that it perhaps ought not to be?), but the text mode for the ought to be western in any event, given a ‘neutral’ character on one side and a western one on the other. Would you consider it a bug if LO fails to change the text mode under such circumstances?

2013-07-01 09:45:23 +0200 commented answer problem with full-width (asian) punctuation

(I write both Chinese and Japanese, btw.)

2013-07-01 09:44:14 +0200 commented answer problem with full-width (asian) punctuation

Thank you for your answer. I'm afraid my problem has nothing to do with the situation you describe, however. If you look closely at my screenshot, you will see that in the incorrect version the opening quotation mark is in a different font. The quotation mark is formatted according to the style specification for "Asian text font". The space in front of it is a normal, half-width space (U+0020) and not an ideographic space (U+3000).

2013-06-30 21:23:12 +0200 received badge  Editor (source)
2013-06-30 21:21:30 +0200 received badge  Student (source)
2013-06-30 20:06:44 +0200 asked a question problem with full-width (asian) punctuation

If I have an East-Asian character in my (predominantly English) document, followed by a quotation mark (opening or closing), the quotation mark uses the full-width version (and it takes the font settings from the "Asian text font" section of the style definition).

For example (see attachment):

if I have the text

日 “sun”

in my document, the opening will be full-width and in a Chinese font (regardless of whether or not I have a space between the character and the quotation mark -- note that the space is normal width...). If I have

日, “sun”

(with the comma) then all is fine.

image description

The only way I can solve this problem is to use direct formatting to force the opening quotation mark to use my "Western text font" (and the appropriate size), which is brittle and not very satisfactory. Is there a setting somewhere that I've over-looked? Or does this seem like a bug that I ought to file?

I would be most grateful for any assistance / advice / suggestions.

Edit:

Apologies if I didn't make this clear: this problem is not to do with the input method I am using; it concerns the rules according to which LO applies the "Western text font" and "Asian text font" settings. Following a logic I can only describe as "buggy", LO formats the (normal-width, western) space and opening quotation mark immediately before the Latin letter "s" according to the "Asian text font" setting.

Edit:

Bug #66791 filed. I suspect bug #60106 is related too.