We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

gunjan's profile - activity

2021-05-17 11:59:34 +0200 received badge  Famous Question (source)
2020-07-19 00:57:35 +0200 received badge  Notable Question (source)
2020-07-19 00:57:35 +0200 received badge  Popular Question (source)
2020-05-03 17:19:41 +0200 received badge  Famous Question (source)
2018-11-07 12:03:19 +0200 received badge  Famous Question (source)
2018-04-08 13:01:18 +0200 received badge  Famous Question (source)
2018-01-31 14:12:37 +0200 asked a question Is administrative rights required to start Libre Office

Is administrative rights required to start Libre Office Hi, We are using Libre Office 5.4.4.2. We are aware that for in

2017-12-06 09:28:46 +0200 marked best answer Python Core Upgrade and Fix

Hi,

We are using Libre Office 5.3.4.2. There were some security vulnerabilities related to Python reported on the same. To resolve them we thought upgrading to Libre Office 5.4.0.3.

The latest version of Libre Office 5.4.0.3 uses Python 3.5.0 which also posses the following security risks: -

  1. CVE-2016-5636: Integer overflow in the get_data function in zipimport.c in CPython (aka Python) before 2.7.12, 3.x before 3.4.5, and 3.5.x before 3.5.2 allows remote attackers to have unspecified impact via a negative data size value, which triggers a heap-based buffer overflow.
  2. CVE-2015-5652: Untrusted search path vulnerability in python.exe in Python through 3.5.0 on Windows allows local users to gain privileges via a Trojan horse readline.pyd file in the current working directory. NOTE: the vendor says "It was determined that this is a longtime behavior of Python that cannot really be altered at this point."

Can we upgrade the Python to 3.5.4 by replacing the folders?

Please suggest.

We use Libre Office on Windows and Linux.

Best Regards, Gunjan Aggarwal

2017-12-06 09:15:31 +0200 marked best answer Which version of Firebird is used in LibreOffice 5.4.1.2 (Windows)?

There are many security vulnerabilities that exist in Firebird 2.0. Following is the list of them: - CVE-2007-3181 CVE-2007-3527 CVE-2007-4664 CVE-2007-4665 CVE-2007-4666 CVE-2007-4667 CVE-2007-4668 CVE-2007-4669 CVE-2007-5246 CVE-2008-0387 CVE-2008-0467 CVE-2009-2620

If LibreOffice is using 3.0 or above then it should be fine. Can somebody confirm the same?

2017-11-15 04:25:46 +0200 received badge  Notable Question (source)
2017-11-10 16:08:47 +0200 received badge  Popular Question (source)
2017-11-10 06:49:41 +0200 asked a question Which version of Firebird is used in LibreOffice 5.4.1.2 (Windows)?

Which version of Firebird is used in LibreOffice 5.4.1.2 (Windows)? There are many security vulnerabilities that exist i

2017-10-11 15:35:14 +0200 received badge  Notable Question (source)
2017-10-11 10:55:24 +0200 received badge  Organizer (source)
2017-10-11 10:54:44 +0200 edited question LibreOffice Security Fix

OpenSSL Security Fix Hi, We are using LibreOffice 5.4.1.2 on both Windows and Linux. OpenSSL used by LibreOffice is of

2017-10-11 08:48:31 +0200 received badge  Popular Question (source)
2017-10-10 12:25:40 +0200 commented question LibreOffice Security Fix

Can we replace the DLL with the 1.0.2l ?

2017-10-09 12:15:27 +0200 asked a question LibreOffice Security Fix

OpenSSL Security Fix Hi, We are using LibreOffice 5.4.1.2 on both Windows and Linux. OpenSSL used by LibreOffice is of

2017-10-09 12:06:51 +0200 received badge  Notable Question (source)
2017-08-24 06:16:38 +0200 received badge  Popular Question (source)
2017-08-22 12:42:32 +0200 commented answer Python Core Upgrade and Fix

Thanks for all the information Mike.

2017-08-22 12:37:45 +0200 commented answer Python Core Upgrade and Fix

Thanks Mike. It does help. Any idea about the release date of next minor release of LO 5.4.0?

2017-08-22 12:37:13 +0200 answered a question Python Core Upgrade and Fix

Thanks Mike. It does help. Any idea about the release date of next minor release of LO 5.4.0?

2017-08-22 12:01:16 +0200 asked a question Python Core Upgrade and Fix

Python Core Upgrade and Fix Hi, We are using Libre Office 5.3.4.2. There were some security vulnerabilities related to