Haz tu Pregunta
0

Me falla formula SI cuando la condicion es una formula que devuelve verdadero o falso

preguntado 2017-11-29 19:23:37 +0200

Imagen Gravatar de leo3487

updated 2017-11-29 19:26:25 +0200

Buenas, este es mi problema:

Tengo una planilla que en la columna A pongo la descripción de un producto, y en la columna B me sale el precio

Obviamente para eso uso la formula Buscarv pero si el producto ingresado no está en la lista, en la columna B me sale el error #N/D

Pero como quiero que no aparezca el codigo de error en el formulario impreso, le pongo una funcion SI adelante, pero no funciona, porque al devolver error el buscarv, imprime el error.

Entonces se me ocurre usar una columna auxiliar para buscarv, y además otra auxiliar donde una función ESERROR me devuelve verdadero si hay error en la celda del buscarv o falso si no hay error

A = descripcion del producto

B = Valor del producto. SI(H1;"";G1)

G = Columna auxiliar donde hago el BUSCARV(A1;A42:B433;2) - Si no se encuentra el producto acá me sale #N/D

H = Columna auxiliar donde averiguo si en G hay error. ESERROR(G1)

Cuando pongo en A1 un producto que no está en la lista, B1 figura en blanco (anda joya toda la carambola que hice) Pero cuando en A1 pongu on producto de la lista, en B1 me dice VERDADERO en vez del valor que figura en G1

Calc 5.3.4.2

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

1 Responder

Ordenar por » viejos nuevas más votado
1

respondido 2017-11-29 23:02:45 +0200

Imagen Gravatar de m.a.riosv

Puedes utilizar la función SI.ERROR(BUSCARV(A1;A42:B433;2);""), si el primer parámetro es un error devuelve el segundo, sino es un error devuelve su valor.

edit marcar como ofensivo delete enlace mas

Comments

Hice como dijiste

=SI.ERROR(BUSCARV(A15;A42:D433;4;0);"")

Pero me vuelve a poner VERDADERO cuando encuentra un valor valido

Por cierto será el formato del archivo? es un .xlsm hecho originalmente en Excel 2016 o será solamente que lo crearon en Excel?

Lo más loco es que en el asistente de funciones me dice que está devolviendo el valor correcto ( en este caso 1029704

Imagen Gravatar de leo3487 leo3487 ( 2017-11-30 12:31:49 +0200 )edit

Lo solucioné pero a medias. Anda pero no creo que sea la solución correcta (o no deberia)

En la columna A ingreso el producto deseado

En la columna G (una auxiliar) hago el BUSCARV

En la columna B hago SI.ERROR(G1;"")

Pero a la columna B le tuve que poner formato Texto

Imagen Gravatar de leo3487 leo3487 ( 2017-11-30 15:23:14 +0200 )edit

¿has probado cambiando el formato la formula?, cualquier celda formateada con 'valor booleano' devuelve verdadero para cualquier valor distinto de cero.

Imagen Gravatar de m.a.riosv m.a.riosv ( 2017-11-30 15:59:26 +0200 )edit
Ingresa/Regístrate para Contestar

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2017-11-29 19:23:37 +0200

Visto: 950 veces

Ultima actualización: Nov 29 '17