Haz tu Pregunta
0

Estilo de formato de numeros no se aplica con formato condicional en Calc

preguntado 2019-06-02 21:42:06 +0200

Imagen Gravatar de Davidoff

updated 2019-06-03 03:38:13 +0200

Buenas. Estoy intentando aplicar un formato de numeros tal que así: 0,##" ms" en la celda C5 con un formato condicional cuando la celda C4 contiene determinado texto. La formula del formato condicional queda así: $C$4="MILISEGUNDOS" y aplico el estilo que contiene el formato de números personalizado.

Lo que quiero concretamente es cambiar el formato del numero que sea seguido por un texto un otro según lo que elija en la celda de arriba como lista desplegable.

El problema es que el formato de números no se aplica y el número se visualiza siempre igual con el formato estandar.

No entiendo que pasa, porque los otros estilos con fondos y tamaños y colores si los aplica, como el estilo ACCEPT, TEXT etc. Saludos.

C:\fakepath\calculadora de tiempo.ods

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

Comments

Si quieres que alguien pueda ayudarte, por favor adjunta un fichero de ejemplo para estudiarlo.

Imagen Gravatar de m.a.riosv m.a.riosv ( 2019-06-02 22:33:52 +0200 )edit

@m.a.riosv Ya he adjuntado el archivo.

Imagen Gravatar de Davidoff Davidoff ( 2019-06-03 00:17:50 +0200 )edit

2 Respuestas

Ordenar por » viejos nuevas más votado
0

respondido 2019-06-03 03:33:16 +0200

updated 2019-06-03 14:24:13 +0200

Fórmula incorrecta, cambie D4 a C4:

=SE(D4="MILISEGUNDOS";60/B5*1000; 60*1000/B5)

correcto:

=SE(C4="MILISEGUNDOS";60/B5*1000; 60*1000/B5)

Pero tiene algo mal, el resultado es el mismo, revisar la fórmula.


ATENCIÓN: Si desea dar más detalles a su pregunta, utilice edit en la pregunta o add a comment abajo. Agradecido.

Si la respuesta atendió su necesidad, por favor, haga clic en la bolita Descrição da imagem a la izquierda de la respuesta, para finalizar la gunta.

edit marcar como ofensivo delete enlace mas
0

respondido 2019-06-03 09:55:20 +0200

Imagen Gravatar de m.a.riosv

Creo que el problema es que tiene un formato directo en D5, y el formato directo prevalece sobre el condicional.
Eliminalo con Ctrl-M.
Crea uno que quieras que tenga cuando no cumple el formato condicional, y aplícalo a D5.

edit marcar como ofensivo delete enlace mas
Ingresa/Regístrate para Contestar

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2019-06-02 21:42:06 +0200

Visto: 19 veces

Ultima actualización: Jun 03