Desactivada la ejecución de macros

preguntado 2019-10-09 13:59:56 +0200

Imagen Gravatar de PedroL

Desde que migré a Firebird (recientemente) cada vez que intento abrir un formulario me da un error que dice que este documento contiene macros y debido a las especificaciones de seguridad establecidas en las Preferencias se ha desactivado parcialmente su ejecución. Sin embargo las especificaciones de seguridad no las he modificado y antes no salía el dichoso warning. He intentado definir el origen de confianza añadiendo la carpeta donde guardo mis bases de datos, pero no parece surtir ningún efecto. ¿Alguien sabe como deshacerse del molesto warning sin bajar el nivel e seguridad a cero? Gracias anticipadas.

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

Comments

Bajandolo a cero, ¿funciona?

Imagen Gravatar de m.a.riosv m.a.riosv ( 2019-10-09 21:44:10 +0200 )edit

Sí. Pero no es una solución que me guste. Hasta ahora estaba configurado en un nivel de seguridad alto y al cambiarme a LO 6.2.7 y 6.3 y migrar a Firebird me ha empezado a dar este problema.

Imagen Gravatar de PedroL PedroL ( 2019-10-10 10:02:18 +0200 )edit

Prueba Menú/Ayuda/Reiniciar en Modo Seguro, para asegurarte que no ha habido alguna corrupción del perfil de usuario al actualizar LibO

Imagen Gravatar de m.a.riosv m.a.riosv ( 2019-10-10 15:09:11 +0200 )edit

He intentado el reinicio en modo seguro, pero no estaba seguro de qué opciones seleccionar por lo que simplemente he reiniciado sin éxito. También he probado el método que yo conocía de renombrar el user y dejar que LO cree un user nuevo, pero tampoco ha habido éxito. El problema se ha presentado al actualizar a LO 6.2.7. Supongo que será un bug de esta versión.

Imagen Gravatar de PedroL PedroL ( 2019-10-15 15:03:32 +0200 )edit

Puedes Crear un informe de error, por favor añade al mismo un fichero de ejemplo para pruebas, con el fin de que se pueda confirmar el problema.

Imagen Gravatar de m.a.riosv m.a.riosv ( 2019-10-15 21:38:58 +0200 )edit