Haz tu Pregunta
0

Calcular promedio

preguntado 2020-10-26 18:51:07 +0100

Imagen Gravatar de Moltke

updated 2020-10-26 18:54:09 +0100

Hola a todos!

En una hoja de calc tengo esta formula para calcular el promedio =SI.ERROR(PROMEDIO(D5:I5);"") y funciona correctamente, hasta cierto punto, ya que puede que alguna(s) celda(s), o incluso todas, no tengan ningún valor, estén en blanco, lo cual genera un problema; el promedio mostrado en J5 no es exacto. Por ejemplo, digamos que en ese rango de celdas D5:I5 solo D5 contiene un valor, el resultado mostrado en J5 debería ser el obtenido de la división de ese valor entre el numero de celdas, en este caso 6, sin embargo, si el valor de D5 es 12 en J5 se muestra 12 y no 2, como debería ser, entonces mi pregunta es, ¿que formula/función debería/puedo utilizar para que eso ocurra? Probé con =PROMEDIO.SI pero no me funcionó, probablemente lo hice mal. Gracias de antemano por sus respuestas.

edit re-etiquetar marcar como ofensivo cerrar fusionar delete

1 Responder

Ordenar por » viejos nuevas más votado
1

respondido 2020-10-26 22:56:29 +0100

Imagen Gravatar de LeroyG

Si quieres que el resultado de PROMEDIO dé 2, las demás celdas deberían tener el valor 0.

En el caso que mencionas, puedes optar por otra combinación de funciones en lugar de la planteada: SUMA(D5:I5)/(CONTAR(D5:I5)+CONTAR.BLANCO(D5:I5)).

LibreOffice 6.4.7.2 (x86); OS: Windows 6.1


Agregar Respuesta está reservado para las soluciones.

Si deseas agregar más información, pulsa en edit (bajo tu pregunta); también puedes agregar comentarios a una respuesta.

Marca la tilde (Correct answer mark) que está a la izquierda de la respuesta que solucione tu inconveniente.

edit marcar como ofensivo delete enlace mas

Comments

@LeroyG muchas gracias, use tu formula y esa cumple la tarea, sin embargo, en J5 muestra un 0 aún sin dato alguno y me preguntaba si es posible que ese 0 no aparezca allí. Por cierto, uso LibreOffice 7 en Debian Buster x64.

Imagen Gravatar de Moltke Moltke ( 2020-10-26 23:18:35 +0100 )edit

Para evitar el "0", puedes usar =SI(SUMA(D5:I5)=0;"";SUMA(D5:I5)/(CONTAR(D5:I5)+CONTAR.BLANCO(D5:I5))), o elige menú Herramientas - Opciones - LibreOffice Calc - Ver, y desmarca Valores cero.

Imagen Gravatar de LeroyG LeroyG ( 2020-10-27 00:15:04 +0100 )edit

@LeroyG 1 millón de gracias amigo! La formula funciona a la perfección :D De verdad muchísimas gracias. Pase el día de ayer y hoy "jugando" con esas funcionas tratando de hallar una solución y algunas o me daban error #DIV/0! o otra cosa, no recuerdo ya de tantas que probé jajaja así que de verdad que muchas gracias!

Imagen Gravatar de Moltke Moltke ( 2020-10-27 00:25:02 +0100 )edit
Ingresa/Regístrate para Contestar

Herramientas de Preguntas

1 seguidor

Estadisticas

Preguntado: 2020-10-26 18:51:07 +0100

Visto: 30 veces

Ultima actualización: Oct 26