Poser votre question

Historique des modifications [retour]

cliquez pour afficher/masquer la modification 1
version initiale

Savoir qu'une ligne est manquante est assez aisé. J'ai ajouté une colonne dans la feuille avec la formule

=SI(OU(B3-B2=100;B3-B2=4100;B3-B2=-235900);"";"***")

à partir de la deuxième ligne de donnée. Si les échantillons sont bien séparés d'une minute, la cellule est vide. Si l'intervalle entre 2 échantillons n'est pas d'une minute, *** apparaît. Vous pouvez adapter à ce que vous voulez faire ensuite. Notez que la rupture de régularité de l’échantillonnage (passage à ----46 au lieu de ----00 et inversement) est aussi signalée.

Il est certainement possible de compenser les échantillons manquants par macro mais je ne l'ai jamais fait.

Personnellement, je préférerais agir à la source, ce qui me semble plus simple, mais cela nécessite de la programmation. Un petit démon connecté au dispositif qui envoie les échantillons pourrait vérifier qu'aucun ne manque en comparant l'horodatage au précédent. S'il en manque un, il lui suffit d'un construire un (ou plusieurs) et de l'envoyer avant l'échantillon réel. Quand j'écris "construire", je pense à une interpolation, simple ou à base de filtre de Kalman. La sortie de ce démon est connectée au "logiciel d'accumulation" (soit Xnet_Meteo s'il a recours à un socket externe pour récupérer les échantillons, ce qui permet de se substituer au socket, soit un autre qui alimente le fichier).

ATTENTION! Si vous enregistrez votre feuille en .xls(x), vous risquez de tomber sur des problèmes de compatibilité. Enregistrez toujours les fichiers en "natif-application", sauf, au dernier moment, pour les transmettre à quelqu'un d'autre.