Poser votre question
1

Comment intercaler une ligne automatiquement dans une nouvelle feuille de calcul ?

posée 2018-10-03 18:28:16 +0200

Image Gravatar de Bristow_69

Soit un tableau dans une feuille. Je souhaiterai obtenir le même tableau dans une nouvelle feuille mais en y intercalant une ligne vide entre 2 ligne.

Voici en exemple :

Feuille 1 :

ABCDE
QSDFG
UIOPM

Feuille 2 :

ABCDE

QSDFG

QSDFG

Merci :)

éditer requalifier signaler fermer fusionner supprimer

1Réponse

1

répondue 2018-10-06 07:59:02 +0200

Image Gravatar de pierre-yves samyn

Bonjour

Ci-dessous un exemple pas à pas (sur la même feuille pour que cela tienne sur la copie d'écran) :

copie ecran des formules décrites après

  • En colonne B : =ENT(LIGNE()/2+1) génère une suite de nombres répétés
  • En colonne C : INDEX($A$1:$A$6;ENT(LIGNE()/2+1)) recherche dans la col. A en utilisant B, on a donc deux fois le libellé (puisque B contient des nombre répétés).
  • En colonne D : SI(EST.IMPAIR(LIGNE(A1)) permet de ne pas avoir de doublon

La formule complète : =SI(EST.IMPAIR(LIGNE(A1));SIERREUR(INDEX($A$1:$A$6;ENT(LIGNE()/2+1));"");"")

C:\fakepath\decaler.ods

Cordialement

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2018-10-03 18:28:16 +0200

Consultée: 83 fois

Mise à jour: Oct 06 '18