Poser votre question
0

calcul conditionnel

posée 2018-11-14 20:46:12 +0200

Image Gravatar de Omalanp

Bonjour, Je pose mon problème: J'ai 2 colonnes: A1: A200 ( Codification) et B1: B200 ( Montant à calculer )

Cellule B201 : =somme(B1:B200)

Je voudrais que la cellule B201 additionne toutes les lignes de la colonne B1:B200 sauf lorsqu'il y a un code particulier (exemple : "V" ) sur 1 ligne de la colonne A1:A200.

éditer requalifier signaler fermer fusionner supprimer

4Réponses

1

répondue 2018-11-20 14:27:27 +0200

Image Gravatar de Patrick47

Bonjour,

La solution la plus simple (déjà prévues dans calc) avec cette formule : =SOMME.SI.ENS(C2:C10;A2:A10;"";B2:B10;2) dans la mesure ou il n'y a que "V" ou une chaine vide "" dans les cellules de la colonne A En reprenant le fichier d'exemple de jmp. C:\fakepath\Exemple.ods Cordialement Patrick

éditer signaler supprimer permalien plus
0

répondue 2018-11-16 12:39:31 +0200

Image Gravatar de Headwar

Bonjour,

on peut tricher avec un produit : =SOMMEPROD((A1:A200<>"V");(B1:B200=1);C1:C200) si une condition est fausse, LO renvoie 0 dont le produit est nul.

C'est triché, c'est mal, mais ca marche ;)

éditer signaler supprimer permalien plus

Commentaires

Evitez someprod, la multiplication de 2 matrices consomme plus de ressources systèmes. Sur 2 colonnes, ça va, mais sur des 10aines de colonnes avec des milliers de tuples, moins.

Image Gravatar de wgetwget ( 2018-11-29 23:32:50 +0200 )éditer
0

répondue 2018-11-15 14:38:34 +0200

Image Gravatar de jmp

updated 2018-11-15 15:35:06 +0200

Dans une quatrième colonne D, la formule

=SI(A1<>"V";SI(B1=2;0;C1))

à descendre jusqu'en D200 donne le résultat attendu.

ou avec cette formule en bas de colonne des données (sans quatrième colonne) :

=SOMME(C1:C200)-SOMMEPROD((A1:A200)="V";(B1:B200)=2;C1:C200)

Voir le court fichier joint à titre d'exemple :

C:\fakepath\Calcul 2 critères.ods

éditer signaler supprimer permalien plus
0

répondue 2018-11-15 10:10:13 +0200

Image Gravatar de Omalanp

Je modifie un peu ma demande avec 3 colonnes. A1:A200 ( Tri .... ex: "V" pour variante) B1:B200 ( Code TVA 1 2 3 ) C1:C200 ( Montant à calculer ) Je voudrais additionner toutes les lignes de la colonne C1:C200 en excluant les lignes contenant "V" de la col A et pour lesquelles la TVA "2" col B par exemple est vérifiée. J'ai essayé cette formule sans résultat: somme.si(et(A1:A200;"<>V";B1:B200;"=2");C1:C200)) Un avis Merci

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2018-11-14 20:46:12 +0200

Consultée: 49 fois

Mise à jour: Nov 20 '18