Poser votre question
0

somme de lettres

posée 2019-05-28 16:04:12 +0100

Image Gravatar de tibi97427

updated 2019-05-28 21:32:56 +0100

Bonjour,

Etant une bille en tableur, je me tourne vers vous en espérant que vous pourrez m'aidez. Si possible assez vite mais sinon ce n'est pas grave. Donc dans Calc j'aimerai faire une formule qui compte le nombre de fois où la lettre A, B, C, D, E apparaît dans une plage de cellules. C'est pour ensuite faire des pourcentages et ainsi avoir des statistiques appréciable qui permettrait de voir en un coup d'oeil quelle lettre ressort le plus souvent. Enfin je pense que je devrais pouvoir m'en sortir pour transformer toutes ces données en joli graphique mais chaque chose à la fois : déjà je bloque sur la création de la formule.

Je mets ici mon fichier test pour que ce soit plus simple à comprendre.

éditer requalifier signaler fermer fusionner supprimer

1Réponse

0

répondue 2019-05-28 16:49:16 +0100

Image Gravatar de pierre-yves samyn

updated 2019-05-28 17:10:19 +0100

Bonjour

Une solution simple est de supprimer la lettre recherchée, pour comparer la longueur de la chaîne avant et après, par exemple pour la lettre "a" :

=NBCAR(A1)-NBCAR(SUBSTITUE(A1;"a";""))

Ceci fonctionne si le texte est dans une seule cellule. Dans le cas où on désire traiter une plage, on peut au préalable "joindre" les cellules comme ceci :

=JOINDRE.TEXTE(""; 1; A1:A2)

puis compter avec la formule précédente.

Les paramètres de JOINDRE.TEXTE sont :

  • le séparateur à insérer entre les chaînes (ici aucun)
  • ignorer les cellules vides (ici VRAI)
  • la plage à joindre

[Ajout]

Une autre possibilité, pour ne pas devoir joindre la plage :

=SOMMEPROD(NBCAR(A1:A3)-NBCAR(SUBSTITUE(A1:A3;"a";"")))

Cordialement

éditer signaler supprimer permalien plus

Commentaires

Merci beaucoup, mais je penche plutôt pour ta 2ème formule, car la première augmente la taille d'une cellule de façon... conséquente.

Image Gravatar de tibi97427tibi97427 ( 2019-05-28 21:42:11 +0100 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-05-28 16:04:12 +0100

Consultée: 144 fois

Mise à jour: May 28 '19