Poser votre question
0

calc FORMULE

posée 2019-07-26 13:58:34 +0200

Image Gravatar de Jim2wild

Bonjour, je suis entrain de préparer un cadre pour jouer au yam's et j'ai une formule que je ne trouve pas exemple : A ma case C11 je désire faire apparaître la somme des cases c3 à c8 mais la majorer de 35 (case C10) si la somme fait plus de 63 sinon marquer la somme sans majoration

J'espère me faire comprendre... je me tiens à votre dispo pour plus ample rgts Merci pour vos réponses

éditer requalifier signaler fermer fusionner supprimer

2Réponses

0

répondue 2019-07-27 08:42:36 +0200

Image Gravatar de Jim2wild

La question a reçu une réponse appropriée. Elle est considérée comme résolue. Merci

éditer signaler supprimer permalien plus
0

répondue 2019-07-26 18:02:17 +0200

Image Gravatar de pierre-yves samyn

Bonjour

La fonction SI permet de faire des tests : si une condition est remplie, faire quelque chose, sinon faire autre chose. On peut donc résoudre ton problème avec par exemple : =SOMME(C3:C8)+SI(SOMME(C3:C8)>63;35;0)

Il est toutefois possible de faire plus court avec une formule du type : =SOMME(C3:C8)+(SOMME(C3:C8)>63)*35

L'expression SOMME(C3:C8)>63) renvoie VRAI (1) ou FAUX (0) selon le cas.

  • Dans le cas où c'est vrai on multiplie 35 par 1 ce qui donne 35
  • Dans le cas où c'est faux on multiplie 35 par 0 ce qui donne 0

On peut faire encore un peu plus court avec : =SOMME(C3:C8)+(ACTUELLE()>63)*35

Comme son nom l'indique la fonction ACTUELLE renvoie la valeur courante de la cellule (donc le résultat de SOMME(C3:C8))

Voir sommesi.ods

Cordialement

éditer signaler supprimer permalien plus

Commentaires

Je voudrai te remercier pour cette réponse rapide. Appliquée sur la feuille de jeu cela fonctionne à merveille. Un grand merci. Avec mon épouse nous allons apprécier cette feuille de résultat du jeu yam's. C'est un réel plaisir. Encore merci. Bien à vous

Image Gravatar de Jim2wildJim2wild ( 2019-07-27 08:40:22 +0200 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-07-26 13:58:34 +0200

Consultée: 32 fois

Mise à jour: Jul 27