Bouton de formulaire qui ont la "tremblote"

posée 2019-10-10 12:54:50 +0200

Image Gravatar de cal

updated 2019-10-10 14:51:43 +0200

Image Gravatar de ajlittoz

Bonjour à tous

J'ai associé un macro à un bouton et lorsque je désactive le mode conception, le bouton se met à trembler (non se n'est pas une blague !!!), je ne peux plus sélectionner quoique se soit dans la feuille de calcul. Y aurait-il un génie parmi vous qui aurait une solution ?

OS Windows 10 LO 6.3.2.2

Macros en question :

 sub INSERLIGNE
 rem ----------------------------------------------------------------------
 rem define variables
 dim document   as object
 dim dispatcher as object
 rem ----------------------------------------------------------------------
 rem get access to the document
 document   = ThisComponent.CurrentController.Frame
 dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

 rem ----------------------------------------------------------------------
 dim args1(0) as new com.sun.star.beans.PropertyValue
 args1(0).Name = "ToPoint"
 args1(0).Value = "$A$2"

 dispatcher.executeDispatch(document, ".uno:GoToCell", "", 0, args1())

 rem ----------------------------------------------------------------------
 dim args2(0) as new com.sun.star.beans.PropertyValue
 args2(0).Name = "ToPoint"
 args2(0).Value = "$A$7"

 dispatcher.executeDispatch(document, ".uno:GoToCell", "", 0, args2())

 rem ----------------------------------------------------------------------
 dim args3(0) as new com.sun.star.beans.PropertyValue
 args3(0).Name = "ToPoint"
 args3(0).Value = "$A$2"

 dispatcher.executeDispatch(document, ".uno:GoToCell", "", 0, args3())

 rem ----------------------------------------------------------------------
 dim args4(0) as new com.sun.star.beans.PropertyValue
 args4(0).Name = "Flags"
 args4(0).Value = "R"

 dispatcher.executeDispatch(document, ".uno:InsertCell", "", 0, args4())

 rem ----------------------------------------------------------------------
 dim args5(0) as new com.sun.star.beans.PropertyValue
 args5(0).Name = "ToPoint"
 args5(0).Value = "$C$3"

 dispatcher.executeDispatch(document, ".uno:GoToCell", "", 0, args5())

 rem ----------------------------------------------------------------------
 dim args6(0) as new com.sun.star.beans.PropertyValue
 args6(0).Name = "EndCell"
 args6(0).Value = "$C$2"

 dispatcher.executeDispatch(document, ".uno:AutoFill", "", 0, args6())

 rem ----------------------------------------------------------------------
 dim args7(0) as new com.sun.star.beans.PropertyValue
 args7(0).Name = "ToPoint"
 args7(0).Value = "$C$2:$C$3"

 dispatcher.executeDispatch(document, ".uno:GoToCell", "", 0, args7())

 rem ----------------------------------------------------------------------
 dim args8(0) as new com.sun.star.beans.PropertyValue
 args8(0).Name = "ToPoint"
 args8(0).Value = "$A$2"

 dispatcher.executeDispatch(document, ".uno:GoToCell", "", 0, args8())


 end sub

Merci d'avance

(édité par ajlittoz pour rendre la macro lisible)

éditer requalifier signaler fermer fusionner supprimer

Commentaires

Comme toujours, il manque le minimum dans cette question: OS et version LO, ainsi que la description des circonstances (ici, la connexion de la macro). Pour donner ces précisions, éditez votre question, n'utilisez pas une réponse.

A priori, si le bouton "trembloteé", c'est que la macro se réactive en permanence, provoquant des rafraîchissements d'écran. Elle "boucle", ne rendant jamais la main à Calc. Le mieux serait sans doute de lister la macro dans votre question (si elle n'est pas trop longue).

Image Gravatar de ajlittozajlittoz ( 2019-10-10 13:13:57 +0200 )éditer

Salut,

Je viens de tester le code sous Ubuntu 18.04 avec LO v6.3.2.2 et je n’ai pas rencontré de problème.

La macro était attachée à l'événement 'Exécuter l'action' du bouton.

Image Gravatar de RatslingerRatslinger ( 2019-10-14 03:08:16 +0200 )éditer