Poser votre question
0

Formule logique à compléter dans un tableau de calculs

posée 2019-11-26 17:46:59 +0100

Image Gravatar de icare

updated 2019-11-28 08:51:08 +0100

Bonjour, Désolé pour les imprécisions ... Je reformule ma demande en essayant d'être plus clair. Dans un tableau Calc, j'aimerais compléter l'une de mes formules logiques ci-dessous de manière à prendre en compte la cellule qui précède ou celle plus en amont, mais non-vide, contenant donc le résultat d'un calcul automatique; elle fait partie d'une plage de cellules dans une colonne contenant d'une part des cellules avec des valeurs (nombre ...) et, d'autre part des cellules vides (avec une formule mais sans résultat de calculs), ces dernières correspondant à des périodes d'absence (2 jours de week-end par exemple ou des absences plus longues). La formule très simple que j'utilise actuellement est la suivante : =SI(G357="";"";G357-G356) Dans ma formule, lorsque par exemple G356 et G355 et suivantes situées avant G357 correspondent à des cellules vides (par exemple celles des 2 jours d'un week end pour lesquels je n'ai pas de donnée), la réponse est bien évidemment #VALEUR!. Je suis donc obligé d'intervenir manuellement pour saisir la cellule plus en amont (cellule G354 ou suivantes le cas échéant) correspondant au jour précédent le week end et qui contient un nombre etc ... J'aimerais donc me simplifier la vie en évitant d'intervenir manuellement chaque semaine ou après une périodes d'absence plus longue pour corriger ma formule. Merci bien et à bientôt. icare

éditer requalifier signaler fermer fusionner supprimer

Commentaires

Il faudrait introduire dans la formule un paramètre complémentaire programmant la sélection de la dernière cellule précédente contenant une valeur (chiffre, montant) et excluant donc les cellules vides.

Image Gravatar de icareicare ( 2019-11-26 18:02:44 +0100 )éditer

1Réponse

0

répondue 2019-11-27 08:24:18 +0100

Image Gravatar de pierre-yves samyn

updated 2019-11-28 09:10:10 +0100

Bonjour

Je ne suis pas sûr d'avoir bien compris, désolé si ce n'est pas le cas. La formule suivante te donne la dernière ligne saisie dans la plage :

=MAX(SI(A1:A30<>"";LIGNE(A1:A30)))

Et la fonction INDEX te donne la valeur saisie dans une plage en fonction du n° de ligne.

Voir cet exemple : DernièreSaisie.ods

[Ajout 28-11-19]

J'ai oublié de préciser que la formule ci-dessus étant matricielle elle doit être validée par la combinaison de touches Ctrl+Maj+Entrée (j'ai également corrigé les références en argument de LIGNE, qui doivent être les mêmes que pour MAX)

Cordialement

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2019-11-26 17:46:59 +0100

Consultée: 19 fois

Mise à jour: Nov 28