Poser votre question
0

formule-logique-a-completer-dans-un-tableau-de-calculs

posée 2019-11-29 09:00:27 +0100

Image Gravatar de icare

updated 2019-12-02 15:25:13 +0100

Re-bonjour, Je vous remercie pour votre réponse rectificative, mais ce n'est pas encore ce que souhaite obtenir comme résultat dans ma formule. En effet, je souhaite que la 2ème partie de ma formule de calcul située dans la colonne H d'à coté {=SI(G357="";"";G357-G356)}, soit {G357-G356} ne prenne en compte en fait que la dernière et précédente cellule de cette colonne contenant le résultat d'un calcul, ce qui revient à dire qu'elle exclue systématiquement les cellules précédentes situées immédiatement en amont et sans résultat = vides (""),mais contenant toutefois une formule mathématique. Ouf ! pfff ! ce n'est pas toujours facile d'être clair dans la rédaction d'une demande en mathématique et je vous prie de bien vouloir m'en excuser auprès des Administrateurs de AsKLibO. Belle journée et à bientôt peut être ? icare

éditer requalifier signaler fermer fusionner supprimer

Commentaires

Bonjour, Peur-être qu'un petit tableau exemple permettrait de mieux comprendre. Pas forcé de mettre les 357 lignes ni les 12 colonnes mais montrer quelques cas de cellules vides. Jacques

Image Gravatar de Jacques-64Jacques-64 ( 2019-11-29 11:35:38 +0100 )éditer

Re bonjour, J'ai appris entre temps à créer un lien que je vous envoi ci-après qui vous permettra d'accéder à un tableau Calc plus compréhensible. Ma demande précise et rédigée figure en dessous du tableau. On me dit que ma demande ne peut pas forcément obtenir de réponse concernant l'adaptation de ma formule... Je serais déçu si c'était le cas.

Merci beaucoup pour votre aide compréhensive et à bientôt.

icare21

https://www.cjoint.com/c/ILcoqdANa5N

Image Gravatar de icareicare ( 2019-12-02 15:25:01 +0100 )éditer

Bonsoir, Je n'ai pas de solution directe. Par contre, avec un (petit) développement BASIC, la solution est simple ;-)

En gros, faire une itération qui remonte les cellules jusqu'à avoir un chiffre. Par contre, le basic LO est plus compliqué que ce que je savais faire en macro MS-Excel. d'où ma question sur la programmation de la fonction DECALER. Ayant la réponse, il n'y a plus qu'à coder (et tester) !!!

à bientôt

Jacques

Image Gravatar de Jacques-64Jacques-64 ( 2019-12-04 00:18:31 +0100 )éditer

2Réponses

0

répondue 2019-12-05 13:49:01 +0100

Image Gravatar de pierre-yves samyn

Bonjour

Donner un classeur exemple permet en effet de mieux comprendre et aussi, évite aux personnes répondant de devoir tenter de recréer un classeur de zéro qui correspond(rait) au problème.

Donc, pour le premier problème (gestion des cellules vides pour la formule en col B) il suffit d'utiliser :

=SIERREUR(A3-A2;"")

Autrement dit, par défaut on fait l'opération et si le résultat est une erreur on affiche "" .

Pour la deuxième question (fond de couleur et caractères gras en A et B pour la valeur la plus élevée) :

  • Sélectionner A2:A21
  • FormatConditionnelConditionCondition1La valeur de la cellule estN éléments supérieurs▸taper 1 dans la zone suivante
  • Choisir le style à appliquer (dans l'exemple ILcoqdANa5N_formule-calculs-30-11-19.ods j'ai choisi Accent3 qu'il est possible de personnaliser ; on peut aussi créer son propre style)

Idem pour la plage B2:B21

Naturellement, il suffit de remplacer 1 par 2, 3, etc. selon qu'on désire mettre en valeur les 2 ou 3 valeurs les plus élevées.

Cordialement

éditer signaler supprimer permalien plus
0

répondue 2019-11-30 18:55:37 +0100

Image Gravatar de icare

colonne A (valeur issue d’1 formule de calculs) colonne B (valeur issue d’1 formule de calculs) Nb carottes sable Nb carottes en bottes Nb carottes lavées (berk!) Nb clopinettes (cela arrive!) A B C D E F 477 477 2 101 53 321 483 960 5 102 54 322 490 973 9 103 55 323 187 677 15 104 56 12 509 696 22 105 57 325 525 1034 35 106 58 326 107 59 9 108 60 328 474 #VALEUR ! 62 22 61 329 446 920 29 25 62 330 497 943 3 111 63 320 396 893 25 25 14 332 113 65 333 114 66 13 115 67 335 116 68 336 3 69 43 547 #VALEUR ! 21 118 70 338 219 766 22 119 71 7

Non non, je ne suis pas un lapin ! L’objectif recherché est de paramétrer la formule des cellules de la colonne B pour exclure les cellules vides immédiatement précédentes dans la colonne C, conduisant au résultat #VALEUR ! dans la colonne B, pour aller chercher la dernière et précédente cellule de cette même colonne B contenant une valeur. Le résultat de la formule (à compléter …) serait donc pour la ligne 11, SI(A11= » » ; » »;A11-A8) et Si(A20= » » ; » »;A20-A14) pour la ligne 20 etc …. Par ailleurs, je cherche à introduire un paramètre de fond de couleur dans la cellule (jaune ou vert etc.) et faisant également apparaître les chiffres en gras dans les cellule des colonne A et B lorsque les résultats sont le plus élevé dans chaque colonne. Merci à vous tous. icare

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

2 suiveurs

Stats

Posée: 2019-11-29 09:00:27 +0100

Consultée: 38 fois

Mise à jour: il y a 2 jours