Poser votre question
0

Espaces insécables pour les guillemets

posée 2020-03-17 23:20:50 +0100

Image Gravatar de SaturdayNight

Bonsoir, Avant, quand j'écrivais quelque chose sur LibreOffice et que j'utilisais des guillemets (français), les espaces insécables apparaissaient automatiquement, mais ce n'est plus le cas. J'ai coché puis décoché plusieurs fois cette option dans les Options linguistiques mais rien ne change. Comment est-ce que je peux faire en sorte que ces espaces apparaissent automatiquement lorsque je mets des guillemets ? Et comment est-ce que je peux faire en sorte que les espaces insécables s'ajoutent automatique en général, c'est-à-dire avant un point d'exclamation ou d'interrogation ? Je viens de remarquer qu'ils n'apparaissent pas également. Merci

éditer requalifier signaler fermer fusionner supprimer

2Réponses

0

répondue 2020-03-19 09:14:45 +0100

Yes! Merci à @Taznat qui a fait avancer le problème et trouvé une solution au moins temporaire!! Lorsqu'on modifie le Style par défaut, onglet Police, menu Langues, et qu'on choisit Français (Canada), les espaces insécables sont réintroduits après/avant les guillemets ouvrants/fermants. Donc les textes en français doivent être mis en langue française par défaut canadienne! Ceci doit absolument être transmis au développeurs pour qu'ils corrigent le problème, comment faire?

éditer signaler supprimer permalien plus

Commentaires

Vous devez avoir un problème de configuration (LO, système ou ailleurs). J'ai vérifié que l'insertion des espaces insécables fonstionne avec toutes les variantes de français sur ma machine: Fedora Linux 31, kernel 5.5,bureau KDE 5.67.0, LO 6.3.5.2.

Je note que la version de LO n'a pas été mentionnée.Je reste toujours une ou deux versions en arrière pour une raison évidente de stabilité. Si votre version est plus récente que la mienne, il peut s'agir d'une régression (alors, direction les développeurs), sinon passez au crible la configuration.

Image Gravatar de ajlittozajlittoz ( 2020-03-19 10:05:15 +0100 )éditer

La version est en effet récente : LO 6.4.0.3. Le même problème exactement survient sur plusieurs ordis différents et différentes plateformes (Mac et Windows). J'ai même avancé d'un cran : en Français (Canada) les espaces insécables réapparaissent, mais alors ce sont … ceux qui précèdent les points d'interrogation qui disparaissent ! Apparemment toute la ponctuation est correcte quand on choisit Français (Belgique)!

Image Gravatar de SursautSursaut ( 2020-03-21 23:35:53 +0100 )éditer
0

répondue 2020-03-18 02:08:19 +0100

Image Gravatar de ajlittoz

Pour que le remplacement ait lieu, il faut deux conditions.

  • La langue du texte doit être "Français"

    La barre d'état inférieure indique la langue courante (vers le milieu). Si elle n'est pas établie à la bonne valeur, allez dans Outils>Options, Paramètres linguistiques>Langues et réglez la langue par défaut.

  • Le remplacement doit être activé

    Allez à Outils>AutoCorrection>Options d'AutoCorrection, onglet Paramètres linguistiques

    Vérifiez que les options s'appliquent bien au français, sinon sélectionnez-le dans le menu déroulant. Cochez la case de remplacement des guillemets. Inutile de spécifier un caractère de remplacement (à titre de sécurité, appuyez sur Défaut).

    Pour les espaces insécables avant les ponctuations, cochez les cases dans la liste des options spécifiques au français.

Pour montrer à la communauté que la question a trouvé sa réponse, cliquez sur ✓ à côté de la "bonne" réponse, et "votez" en cliquant sur la flèche ^ de toute réponse utile. Ce sont les mécanismes utilisés pour communiquer la qualité des questions et réponses sur ce site. Merci!

éditer signaler supprimer permalien plus

Commentaires

1

Non pas ok. J'ai le même problème. La langue est bien le français (Suisse), les options d'autocorrections sont bien paramétrées. Les espaces insécables sont normalement insérés avant les points-virgules, doubles-points etc, seule l'insertion avant/après les guillemets dysfonctionne. Mais j'ai un indice pour les développeurs. Le problème se pose pour des documents créés avec un modèle Openoffice, mais pas lorsque on créé un document sur la base d'un modèle Libre-office, ni avec un document créé sur la base d'un très vieux modèle Openoffice (autour de 2010). Donc il s'agirait d'un problème de compatibilité de Libreoffice avec les modèles anciens créés sur Openoffice. Comment rectifier les modèles et les documents existants pour supprimer ceci?

Image Gravatar de SursautSursaut ( 2020-03-18 07:40:03 +0100 )éditer

J'ai fait toutes ces manipulations, j'ai même désinstallé LibreOffice puis je l'ai réinstallé deux fois mais rien ne change. Je ne sais pas si ça change quelque chose mais quand je vais dans Outils>AutoCorrection>Options d'AutoCorrection puis dans l'onglet Options linguistiques, je n'arrive pas à ouvrir le menu déroulant bien que la langue française soit sélectionnée. Et, je ne comprends pas pourquoi il n'y a pas de guillemets français, les guillemets simples ne sont pas ce que je cherche et quand je sélectionne les autres guillemets, ils me mettent des guillemets à l'anglaise. Je suis donc obligée de changer les guillemets d'ouverture et de fermeture. Si vous connaissez une méthode pour que les guillemets français soient par défaut, merci de me le dire. J'ai coché les cases dans la liste des options spécifiques au français pour les espaces insécables avant les ...(plus)

Image Gravatar de SaturdayNightSaturdayNight ( 2020-03-18 10:14:27 +0100 )éditer

Je viens de remarquer aussi que bien que j'ai mis la langue du texte en Français dans Outils>Options, Paramètres linguistiques>Langues, lorsque j'ouvre un nouveau document texte, il est en Anglais mais quand je change la langue dans la fine barre en bas de l'interface, à droite de "Style par défaut", les guillemets français apparaissent avec des espaces insécables.

Image Gravatar de SaturdayNightSaturdayNight ( 2020-03-18 10:37:29 +0100 )éditer

Si un nouveau document texte s'ouvre en anglais, regardez dans Outils>Options, Paramètres linguistiques>Langues si la langue par défaut est bien le français. Si oui, modifiez la configuration de Style par défaut, onglet Police. Soit vous appuyez sur Standard, ce qui a pour effet d'aller chercher la langue dans Outils>Options , soit vous la forcez avec le menu déroulant.

Image Gravatar de ajlittozajlittoz ( 2020-03-18 15:27:22 +0100 )éditer

Je suis désolée mais je ne trouve pas l'onglet Police.

Image Gravatar de SaturdayNightSaturdayNight ( 2020-03-19 00:07:19 +0100 )éditer

Merci du commentaire mais ce n'est pas la solution. J'ai vérifié. La langue par défaut est bien le français, et le problème est là. Il faut vraiment chercher en direction de l'incompatibilité d'anciens modèles Openoffice avec Libreoffice. Solution cherchée : peut-on corriger ça sans recopier les documents dans de nouveaux documents créés avec les nouveaux modèles?

Image Gravatar de SursautSursaut ( 2020-03-19 09:01:55 +0100 )éditer
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-03-17 23:20:50 +0100

Consultée: 119 fois

Mise à jour: Mar 19