Poser votre question
0

Résultats outil Recherche et Filtre différents dans Calc

posée 2020-06-08 14:21:15 +0200

Image Gravatar de wil

updated 2020-06-08 14:24:00 +0200

Bonjour, Je travaille sur cette feuille de calcul (Statistique générale de la France ) http://acrh.revues.org/index3130.html Je cherche à compter les lignes dont le LIBELLE contient "MASCULIN" l'outil de recherche et le filtre standard me donnent des résultats différents. RECHERCHE : 1174 FILTRE STANDARD : 3949

éditer requalifier signaler fermer fusionner supprimer

3Réponses

0

répondue 2021-02-12 06:32:21 +0200

Image Gravatar de njhub

Bonjour wil, le forum

En attendant que le "bug" soit résolu, pourquoi ne pas essayer d'utiliser la fonction dédiée :

=NB.SI(C1:C16533;"*MASCULIN*")

:)

Sinon en triant vos données "Recherche" renvoie la bonne valeur

Sachant que la colonne B, servant au tri contient :

=ESTNUM(CHERCHE(B$1;E2))

Dans laquelle B1 est égal à "Masculin"

description de l'image

éditer signaler supprimer permalien plus
0

répondue 2021-02-11 23:09:55 +0200

Image Gravatar de Rakam

Effectivement, même sur LO 7.1.0.3 les mêmes manipulations donnent des résultats identiques et en plus avec autofiltre j'obtiens aussi 3949; avec Rechercher et Remplacer il y en a 1174. BUG BOGUE!

Alors une question se pose: peut-on avoir confiance à 100% à ces différentes fonctions?

éditer signaler supprimer permalien plus

Commentaires

@ Wil, @njhub @pierre-yves

Comme je suis en train de manipuler des milliers de lignes et de colonnes, un gros point d'interrogation a surgit au sujet de mes données (je crois ne pas être le seul!). D'autant plus que je ne contrôle pas Calc à la perfection, par contre j'aime bien la convivialité.

Donc, si on fait Données: Filtre standard: Nom du champ (ici Colonne C) et que l'on demande "CONTIENT" au lieu de "=" (qui ne donne rien en passant; CONTIENT demande dans une ligne texte un mot spécifique, ici "masculin"), on obtient 3949 "masculin".

Et on a la colonne LIBELLE contenant 3949 items "masculin" si on fait un copier-coller sur une autre feuille par contre si l'on reste sur la page filtrée et que l'on demande RECHERCHER (masculin) le résultat est 1174! Pourquoi, parce que je crois que la fonction RECHERCHER lit le classeur ...(plus)

Image Gravatar de RakamRakam ( 2021-02-12 22:20:14 +0200 )éditer
0

répondue 2020-06-09 11:47:54 +0200

Image Gravatar de pierre-yves samyn

Bonjour @wil

En effet... il semble que ce soit un bug dans l'affichage du dialogue des résultats trouvés : la sélection est en revanche correcte (si on supprime les lignes sélectionnées on voit qu'il y en a bien 3949).

Je n'ai pas trouvé de rapport de bug spécifique...

Cordialement

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-06-08 14:21:15 +0200

Consultée: 47 fois

Mise à jour: Feb 12