Poser votre question
0

Compter le nombre de femmes et d'hommes par rapport à une base de donnée?

posée 2020-07-13 11:34:26 +0100

Image Gravatar de Mat8

Bonjour.

Étant nouveau sur le forum, j'espère que ma question est posée au bon endroit.

Je cherche une formule pour compter le nombre de femmes et d'hommes, présents dans l'ensemble de mes groupes, sur la feuille "groupes", de mon fichier. Le but étant de faire apparaitre mes résultats dans la cellule C:21 et C:23.

Je dispose d'une base de données comportant le sexe de chaque personnes dans la feuille "base de données". Je vous joint mon fichier test pour plus de facilité.

J'espère avoir été précis dans mes explication, avec mon langage de novice.

Merci d'avanceC:\fakepath\FICHIER TEST.ods

éditer requalifier signaler fermer fusionner supprimer

3Réponses

1

répondue 2020-07-13 14:21:23 +0100

Image Gravatar de Pioulo

Bonjour,

On peut aussi nommer les plages pour faciliter la compréhension des formules. Par exemple Groupe01 pour $Groupes.$B$2:$B$13, Groupe02 pour $Groupes.$D$2:$D$13 et Noms pour $'base de données'.$A$2:$C$49. Dans l'exemple joint, j'ai ajouté d'autres noms dans base de données, ce qui doit être le cas dans la vraie base (sinon, aucun intérêt à calculer le nombre d'hommes et de femmes sur Groupes si c'est exactement la même liste que base de données). Pour les risques d'erreurs pointés par Pierre-Yves (Nicilos/Nicolas), tu as intérêt à faire une liste de validité pour Groupes liée à base de données : un choix par liste déroulante empêchera ce genre de déconvenue. Ainsi, la formule pour dénombrer les femmes présentes sur les deux groupes, en C21 de Groupes pourrait être :

=NB.SI(SIERREUR(RECHERCHEV(Groupe01;Noms;3;0);"");"F")+NB.SI(SIERREUR(RECHERCHEV(Groupe02;Noms;3;0);"");"F")

et pour les hommes en C23 :

=NB.SI(SIERREUR(RECHERCHEV(Groupe01;Noms;3;0);"");"M")+NB.SI(SIERREUR(RECHERCHEV(Groupe02;Noms;3;0);"");"M")

Ces formules sont matricielles (à valider par Ctrl+Maj+Entrée). Le fait d'utiliser (solution de Pierre-Yves) ou non (ici) des colonnes intermédiaires est à choisir en fonction de la clarté et de la maintenance, mais de toute façon, il faut bien stocker l'information quelque part (ici RECHERCHEV crée en matriciel, virtuellement, la colonne intermédiaire).

C:\fakepath\SommeGenre_Piou.ods

Cordialement,

éditer signaler supprimer permalien plus

Commentaires

j avais une question mais j ai trouvé ma réponse dans la faq Merci

Image Gravatar de Tambour21Tambour21 ( 2021-01-29 13:53:32 +0100 )éditer
1

répondue 2020-07-13 12:00:51 +0100

Image Gravatar de pierre-yves samyn

Bonjour @Mat8

Plutôt que de tout réunir dans une seule formule difficile à comprendre le mieux est de passer par des "calculs" intermédiaires (col. F et G dans l'exemple) afin de rechercher l'information pour chaque groupe, par exemple avec une formule du type :

=INDEX('base de données'!$C$2:$C$25;EQUIV(B2;'base de données'!$A$2:$A$25;0);1)

Ensuite, en C21 et C23 il suffit de compter, par exemple avec =NB.SI($F$2:$G$13;"F")

Voir test.ods

Cela dit j'attire ton attention sur les erreurs de saisie possibles (cf. ton exemple NICILOS), sur les prénoms identiques, et sur les prénoms épicènes (Claude, Dominique...).

Cordialement

éditer signaler supprimer permalien plus
0

répondue 2020-07-21 12:18:19 +0100

Image Gravatar de Mat8

Merci beaucoup pour vos contributions. Je vais pouvoir avancer sur mon fichier grâce à vous.

éditer signaler supprimer permalien plus
S'identifier/S'inscrire pour répondre

Outils de question

1 suiveurs

Stats

Posée: 2020-07-13 11:34:26 +0100

Consultée: 69 fois

Mise à jour: Jul 21 '20