Fai la tua domanda
0

La funzione somma fornisce risultato errato

chiesto il 2018-02-12 09:11:15 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Creo un nuovo foglio Calc. Nella prima colonna incollo i seguenti numeri: 0,0086584 0,00159885 0,0016177 0,00164682 0,00151831 0,00155874 Se nella cella A7 metto la formula =SOMMA(A1:A6) (che ottengo premendo l'icona per somma) ottengo il risultato erroneo 0,0016177 Se invece metto la formula = a1 +a2 + a3 + a4 +a5+ a6 ottengo il risultato corretto, ovvero 0,01659882

E' un errore mio di qualche tipo, oppure c'è un bug?

modifica retag flag offensive close merge delete

4 Answers

0

risposto il 2018-02-13 10:55:37 +0100

Immagine gravatar per mikalzet

Era un problema di formattazione: alcuni numeri in realtà erano testo ( cancellando la formattazione diretta erano preceduti da ', così '0,00675 )

modifica flag offensive delete link more
0

risposto il 2018-02-12 17:03:37 +0100

Immagine gravatar per akurery

updated 2018-02-12 17:08:16 +0100

A me funziona correttamente: qui ho Win10 32bit con LibreOffice 6.0.0.3.
Visto che il risultato errato è uguale al valore che hai in A3. sei sicuro di non aver modificato inavvertitamente la formula della somma selezionando solo la cella A3?
Altra opzione: sicuro che gli altri valori siano stati incollati come numeri e non come stringhe di testo?

modifica flag offensive delete link more
0

risposto il 2018-02-12 16:45:18 +0100

Immagine gravatar per John Tanis

Una volta scritta la formula premi invio invece che sull'icona somma.

modifica flag offensive delete link more
0

risposto il 2018-02-12 09:54:23 +0100

Prima di tutto: quale versione di Calc stai usando?

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2018-02-12 09:11:15 +0100

Seen: 339 times

Last updated: Feb 13 '18