Fai la tua domanda
0

estrarre una stringa dal contenuto di una cella

chiesto il 2019-07-30 16:07:08 +0200

Immagine gravatar per alexraffa

updated 2019-07-30 16:14:04 +0200

Salve a tutti! non riesco ad effettuare questa operazione, ho un foglio calc, popolate da un csv prodotto da un sw, con alcuni campi, tipo così:

stazione | hostname | groups                                  | data
001        | HOST1    | everyone, windows 7, como    | 24/07/2019
002        | HOST2    | everyone, windows 10, lecco   | 21/07/2019

e così via. vorrei aggiungere una colonna in fondo dove far "magicamente" comparire, rispettivamente per ogni riga solo la stringa windows 7 (windows 10) , cioè estrarre la stringa di ricerca dal contenuto della cella e piazzarlo in una cella a sè. Ho provato con cerca, ma non riesco a costruire la formula, chi è già incappato in una situazione simile e potrebbe dare una mano? Grazie

modifica retag flag offensive close merge delete

3 Answers

1

risposto il 2019-07-30 21:08:39 +0200

Immagine gravatar per gioh66

Con il tuo file in mano, e prendendo spunto dall'ultima formula di charlie.it, direi di provare così: in D2 metti

=ANNULLA.SPAZI(STRINGA.ESTRAI(SOSTITUISCI(B2;",";" ");RICERCA("windows";B2);10))

e tira in basso

modifica flag offensive delete link more

Commenti

Perfetto! quello che volevo! il costrutto è un po' astruso, da solo con ci sarei arrivato. Grazie!

Immagine gravatar per alexraffa alexraffa ( 2019-07-30 22:01:33 +0200 )modifica

Di nulla, grazie a te del riscontro!

Immagine gravatar per gioh66 gioh66 ( 2019-07-30 23:26:34 +0200 )modifica

Conferma le risposte con il segno di spunta, aiuterai gli altri nella ricerca.

Immagine gravatar per charlie.it charlie.it ( 2019-07-31 09:56:13 +0200 )modifica
0

risposto il 2019-07-30 16:44:13 +0200

updated 2019-07-30 17:19:08 +0200

La stringa "everyone" è sempre uguale? È sempre seguita da "Windows ..." ? Se sì puoi usare la funzione =STRINGA.ESTRAI(A1;11;10). Unico problema è quello che otterrai una virgola dopo "windows 7," per poter avere completo "windows 10".

Se la mia riposta ti ha aiutato, votala con ✔ (qui a sinistra)

Edit: per evitare la virgola dopo "windows 7": =SE(STRINGA.ESTRAI(A1;19;1)="7";STRINGA.ESTRAI(A1;11;9);STRINGA.ESTRAI(A1;11;10))

Edit2: Prova questa (cerca in tutta la stringa e comincia a copiare quando incontra la parola "windows")

=STRINGA.ESTRAI(A1;CERCA.B("windows";A1;1);10)

modifica flag offensive delete link more
0

risposto il 2019-07-30 16:52:50 +0200

Immagine gravatar per alexraffa

updated 2019-07-30 20:09:16 +0200

Ciao, grazie della risposta, no le stringhe non sono sempre nella stessa posizione, proprio per questo vorrei implementare una "ricerca" all'interno del contenuto della cella per estrarre la stringa di interesse

ecco un file con lo schema indicato, fake naturalmente C:\fakepath\prova-ricerca.ods

modifica flag offensive delete link more

Commenti

Posta un file d'esempio, con le immagini ci si fa poco.

Immagine gravatar per gioh66 gioh66 ( 2019-07-30 17:18:31 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-07-30 16:07:08 +0200

Seen: 22 times

Last updated: Jul 30