Fai la tua domanda
0

Reset automatico di un record

chiesto il 2019-08-15 21:29:22 +0200

Immagine gravatar per Tommaso

Mi è capitato che, compilando una tabella di un database LibreOffice, il record contenente una data (MM/AAAA) venisse sovrascritto con un'altra data (12/1899) scelta arbitrariamente impossibilitandomi la continuazione.Ho provato a creare altre tabelle ma ciò continuava ad accadere. Chiedo quindi come posso far si che ciò non accada. Grazie per il tempo dedicato al post. Cordiali saluti.

modifica retag flag offensive close merge delete

2 Answers

2

risposto il 2019-08-16 12:29:06 +0200

updated 2019-08-16 12:29:45 +0200

Devi aggiungere un modello di data nelle impostazioni di LibreOffice. Vai in Strumenti->Opzioni e scegli Impostazioni della lingua. Quindi sotto Lingue aggiungi in Modelli acccettati per la data il formato M/Y. Conferma e poi riprova sistemando le date nelle tabelle.

descrizione immagine

Ho fatto un piccolo test e funziona.

descrizione immagine

Se risolvi segnala la risoluzione con ✔ qui a sinistra.

modifica flag offensive delete link more

Commenti

Come può essere che a me non funzioni? (LO 6.2.1.2 macOS Sierra). Ho eseguito tutto alla lettera e anche riavviato LO. La modifica dei modelli accettati compare come nel tuo screenshot. Grazie.

Immagine gravatar per charlie.it charlie.it ( 2019-08-16 18:38:19 +0200 )modifica

Mmmh, l'unica differenza che vedo al volo è la versione. Ho testato sulla 6.2.5, provo con versioni precedenti.

Immagine gravatar per Antonio Faccioli Antonio Faccioli ( 2019-08-16 18:40:25 +0200 )modifica

Dimenticavo nella tabella hai creato un formato personalizzato MM/AAAA?

Immagine gravatar per Antonio Faccioli Antonio Faccioli ( 2019-08-16 18:41:55 +0200 )modifica

Certo, ho impostato quel formato.

Immagine gravatar per charlie.it charlie.it ( 2019-08-16 20:16:54 +0200 )modifica

Sì, sospettavo che l'avessi già impostato. Te l'ho detto solo per scrupolo :)

Test fatti Ho provato con la 6.2.5, sia con Firebird sia HSQLDB e funziona

Ho provato con la 6.2.1.2 con Firebird e funziona. Non ho potuto fare un test con HSQLDB perché mi va in errore.

I test li ho fatti con prifilo utente rigenerato.

Tu hai usato Firebird o HSQLDB? Ah io sono su Mojave.

Per curiosità prova a rinominare il profilo utente e rifai la procedura.

Immagine gravatar per Antonio Faccioli Antonio Faccioli ( 2019-08-16 22:54:46 +0200 )modifica

Risolto resettando il profilo utente. (Prove fatte solo con HSQLDB). Grazie.

Immagine gravatar per charlie.it charlie.it ( 2019-08-17 08:22:24 +0200 )modifica
0

risposto il 2019-08-16 08:46:21 +0200

updated 2019-08-16 08:57:51 +0200

In effetti Base sembra non accettare come input il formato MM/AAAA e il sistema sostituisce quanto digitato con 12/1899. Ti consiglio di passare al formato GG/MM/AA e convertirlo in MM/AAAA in una Query.

Se la mia riposta ti ha aiutato, votala con ✔ (qui a sinistra)

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-08-15 21:29:22 +0200

Seen: 11 times

Last updated: Aug 16