Fai la tua domanda
0

immettere data della modifica di una cella

chiesto il 2019-08-28 16:04:52 +0200

Immagine gravatar per Alitfaier

ho applicvato questa funzione =SE($A19<>"";OGGI();"")

Praticamente mi inserisce la data nella cella quando la cella a19 contiene qualcosa, ma vorrei che contenesse la data di modifica e non che mi aggiorni continuamente la data giorno per giorno, è possibile?

modifica retag flag offensive close merge delete

Commenti

Se la formula verrà ricalcolata sempre.

Immagine gravatar per Gilberto Schiavinatto Gilberto Schiavinatto ( 2019-08-28 16:20:28 +0200 )modifica

3 Answers

0

risposto il 2019-09-17 07:35:49 +0200

updated 2019-09-17 08:06:37 +0200

Riprendendo la macro di @Antonio Faccioli, per l'orario il codice sarebbe questo:

Function DataStatica() As Time

oCell = ThisComponent.getCurrentSelection()
oCell.setValue(TimeValue(Now))

End function
modifica flag offensive delete link more
0

risposto il 2019-09-16 15:03:44 +0200

updated 2019-09-16 15:05:01 +0200

Ciao, mi inserisco nella discussione. Se invece che inserire la Data volessi inserire l'Orario???

modifica flag offensive delete link more

Commenti

Volendo ci sono i comandi Inserisci - Data ed Inserisci - Ora, che si potrebbero inserire rapidamente con le combinazioni di tasti Ctrl + ; e Ctrl + Maiusc + ;
Purtroppo queste scorciatorie con la tastiera italiana possono generare un po' di problemi in quanto il ; richiede sempre il tasto Maiusc.
Si possono però ridefinire dal menu Opzioni - Personalizza, nella scheda Tastiera e scegliendo una combinazione di tasti libera, alla quale abbinare le voci che si trovano nella categoria Inserisci e precisamente Inserisci data corrente e Inserisci ora corrente.

Immagine gravatar per akurery akurery ( 2019-09-16 16:53:43 +0200 )modifica
0

risposto il 2019-08-28 16:30:27 +0200

updated 2019-08-28 17:25:06 +0200

Perché quella funzione ti legge la data di oggi e quindi non è quello che cerchi. Credo che la strada ottimale sia quella di costruirti una macro opportuna.

Tipo una cosa così che richiami poi come una funzione normale di Calc

Function DataStatica() As Date

oCell = ThisComponent.getCurrentSelection()
oCell.setValue(DateValue(Now))

End function

Dai una letta a questa paginetta per le funzioni personalizzate.

https://help.libreoffice.org/Calc/Use...

N.B. In questo modo ti scrive la data, ma ti toglie l'eventuale formula presente nella cella sostituendola con la data corrente (che non si aggiorna).

modifica flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-08-28 16:04:52 +0200

Seen: 50 times

Last updated: Sep 17