Fai la tua domanda
0

funzione conta valori univoci con più criteri

chiesto il 2019-10-08 15:55:24 +0200

Immagine gravatar per giuse

updated 2019-10-09 15:59:03 +0200

Vorrei creare una funzione che conta valori (date, o testi) univoci ma con 2 o più criteriC:\fakepath\Test funzioni.odsC:\fakepath\Risposta.ods Seguendo un consiglio ho iniziato con la creazione guidata e si è creata questa funzione =SE(CONTA.PIÙ.SE($F$2:$F$24;"<>T";$G$2:$G$24;"1")=1) ma i risultato è falso! Capisco che non avendo competenze vi faccio perdere tempo....allego il file con inserito nel foglio =SE(CONTA.PIU.SE L'ESEMPIO Un altra limitazione che le funzioni le vorrei inserire nelle celle nelle stese colonne dei ocnteggi (da A a E) come da esempio escludendo cosi funzioni che includono tutte le celle di una intera colonna. Grazie Saluti

modifica retag flag offensive close merge delete

3 Answers

0

risposto il 2019-10-08 22:01:39 +0200

Immagine gravatar per gioh66

updated 2019-10-09 13:36:24 +0200

Salve prova così: in A27 da tirare a destra e in basso, metti

formula sbagliata...vedi sotto quella giusta

Nel file che ti riallego ho messo la formula da A38 in poi. Discostano dai tuoi in rosso, ma se la condizione è che devono essere <>T e per mese mi pare che ci siamo. Fai verifiche...

C:\fakepath\conta valori univoci con più criteri (bis).ods

modifica flag offensive delete link more

Commenti

Ora con calma e concentrazione ci guardo. La cosa che invece mi esce spontanea è grazie per la gentilezza....e poi parlano di egocentrismo e cattiveria nell'uomo! Forse alora tu sarai un eccezzione!!! Poi ti faccio sapere . Nel frattempo hai un consiglio da darmi per trovare in rete un manualetto sintetico come guida per queste funzioni matematiche. Ciao grazie giuse

Immagine gravatar per giuse giuse ( 2019-10-09 09:09:34 +0200 )modifica

Allora ho rivisto con calma la formula e mi sono accorto che qualcosa non quadrava. Poi ho visto la risposta che hai dato a R.C. o meglio la formula e l'ho corretta così

=SE.ERRORE(MATR.SOMMA.PRODOTTO(FREQUENZA(SE(SCARTO($A$1;CONFRONTA($G27;$G$2:$G$24;0);5;CONTA.SE($G$2:$G$24;$G27))<>"T";CONFRONTA(SCARTO($A$1;CONFRONTA($G27;$G$2:$G$24;0);RIF.COLONNA(A$1)-1;CONTA.SE($G$2:$G$24;$G27));SCARTO($A$1;CONFRONTA($G27;$G$2:$G$24;0);RIF.COLONNA(A$1)-1;CONTA.SE($G$2:$G$24;$G27));0));RIF.RIGA(INDIRETTO("A1:A"&CONTA.SE($G$2:$G$24;$G27))))>0);0)

Adesso torna. Riposto sopra anche l'allegato corretto.

Ps.: non so se ci siano manuali per fare le formule. Io ho imparato seguendo forum e video guide dedicate ...(more)

Immagine gravatar per gioh66 gioh66 ( 2019-10-09 13:32:49 +0200 )modifica

Propongo un'altra formula più corta, matriciale, perciò da confermare con la combinazione di tasti ctrl+maiuscolo+invio

In A27 da copiare a destra e in basso

=SE.ERRORE(SOMMA(--(FREQUENZA(SE($F$2:$F$24<>"T";SE($G$2:$G$24=$G27;CONFRONTA(A$2:A$24;A$2:A$24;0)));RIF.RIGA($A$2:$A$24)-1)>0));0)
Immagine gravatar per gioh66 gioh66 ( 2019-10-12 17:53:07 +0200 )modifica

Scusami veramente di cuore. se mi concentrassi di più farei meno ma farei meglio!!!! Le formule sono corrette entrambi ora provo a capirle in modo da poterle utilizzare in modo non passivo. Ti dirò di più , asino sono che ho anche conteggiato manualmente male la cella A29.... Grazie infinite ciao giuse

Immagine gravatar per giuse giuse ( 2019-10-12 19:41:45 +0200 )modifica
0

risposto il 2019-10-08 17:03:39 +0200

Immagine gravatar per R.C.

updated 2019-10-09 09:56:24 +0200

Sarebbe utile un file di esempio.

Se ho ben capito, tu hai una serie di dati in cui vorresti evidenziare solo quelli, caratterizzati da una determinata combinazione di criteri, che ricorrono una volta sola nell'elenco.

Già ti è stata segnalata la funzione CONTA.PIÙ.SE, che ti permette di evidenziare i valori che presentano una determinata combinazione di criteri.

Se ti serve evidenziare, fra tali valori, quelli presenti una sola volta nel tuo elenco, puoi inglobare CONTA.PIÙ.SE in una funzione SE, impostata in modo che ti riporti o ti evidenzi il valore quando CONTA.PIÙ.SE dà per risultato 1, e lasci vuota la cella (si indica con "") in caso contrario.

Per includere CONTA.PIÙ.SE in una funzione SE procedi in questo modo:

1) apri la creazione guidata e costruisci la funzione CONTA.PIÙ.SE seguendo le indicazioni;

2) tagli (escludendo il segno di = all'inizio) la funzione che hai appena costruito;

3) apri la creazione guidata e selezioni la funzione SE;

4) nel campo test incolli la funzione CONTA.PIÙ.SE che hai creato, e siccome ti interessano, se ho ben capito, solo le ricorrenze singole (e non i dati doppi, tripli, ...) completi il test scrivendo =1

5) completi, seguendo le indicazioni della creazione guidata, la funzione SE.

In questo modo puoi generalmente inglobare qualsiasi funzione (o anche più funzioni) in un'altra, secondo le tue necessità. Quando hai preso confidenza, puoi arrivare a costruire dei veri mostri (ti converrà allora tener traccia, in un foglio a parte, di come li hai costruiti, per non impazzire se mesi o anni dopo dovessi modificare qualcosa).

modifica flag offensive delete link more

Commenti

Non saprei creare una funzione che includa SE a CONTA.PIù.SE..!!!!! Vorrei conteggiare i valori univoci da A2 a E24 inserendo una funzione in ogni cella da A 27 a E33 che rispettano i criteri impostati nelle celle da F27 a G33 Le faccio un esempio: nella cella C31 vorrei conteggiare i valori univoci delle aziende che compaiono nella colonna C2/C24 nel mese di Maggio (5)(colonna G) e che hanno nella colonna stato un contenuto diverso (<>)da T vorrei allegarle il file esempio ma non so ocme fare... grazie cordiali saluti giuseppe

Immagine gravatar per giuse giuse ( 2019-10-08 18:50:56 +0200 )modifica

Ti ho modificato la risposta per spiegare come includere una funzione in un'altra.

Immagine gravatar per R.C. R.C. ( 2019-10-09 09:56:54 +0200 )modifica

Non è facile per me gestire le funzioni elencate. Avevo rimediato questa funzione in rete che conteggia valori univoci di ogni colonna (io la inserisco sotto la colonna in cui voglio conteggiare i valori univoci) ma si avvale di un solo criterio e io ne vorrei aggiungere un secondo e anche un terzo criterio e non so come fare . Ti riporto la formula: =SOMMA(--(FREQUENZA(SE($I$2:$I$75="V";CONFRONTA(D$2:D$75;D$2:D$75;0));RIF.RIGA(D$2:D$75)-RIF.RIGA(D$2)+1)>0)) Il foglio di conteggio va da A2 ad T75 Vorrei aggiungere il secondo criterio dopo il primo (dopo "V";) grazie ciao

Immagine gravatar per giuse giuse ( 2019-10-09 10:15:20 +0200 )modifica

Seguendo le chiare istruzioni con la creazione guidata si è creata questa funzione =SE(CONTA.PIÙ.SE($F$2:$F$24;"<>T";$G$2:$G$24;"1")=1) che genera Falso, mentre io avrei bisogno che compaia in questo caso di un numero come 1 oppure 2 oppue 5....il conteggio dei solo valori univoci di testo inseriti nella parte di colonna che soddisfa i 2 criteri

Immagine gravatar per giuse giuse ( 2019-10-09 15:27:38 +0200 )modifica

Costruendo la funzione SE, hai riempito il campo "Altrimenti il valore" con quello che vuoi far comparire nel caso che non sia soddisfatta la condizione CONTA.PIÙ.SE(...)=1?

Se quel campo resta vuoto e il test non è soddisfatto, il sistema ti risponde FALSO.

Immagine gravatar per R.C. R.C. ( 2019-10-09 17:48:13 +0200 )modifica

come ad esempio se viene vero inserisco 1 e comparw 1 altrimenti 0. Il problema che se è falso mi sta bene 0 ma se è vero vorrei che apparisse il numero di testi univoci...cosa dovrei inserire in "Altrimenti il valore"?

Immagine gravatar per giuse giuse ( 2019-10-09 19:04:23 +0200 )modifica

non esiste una guida che spiega bene come si ocstruisce una funzione che include conteggio di valori univoci a più criteri? In modo da non impegnare voi ad un corso step by step?

Immagine gravatar per giuse giuse ( 2019-10-09 19:09:46 +0200 )modifica

Costruendo una funzione SE, in "Altrimenti il valore" si mette solo ciò che si vuol avere nel caso il "test" non venga soddisfatto. La combinazione SE(CONTA.PIÙ.SE(...)=1;... ti serve se vuoi evidenziare soltanto i record che ricorrono una sola volta. Se invece ti basta sapere quante volte ricorre un record con una certa combinazione di dati, ti basta CONTA.PIÙ.SE.

Non conosco guide specificamente dedicate alle funzioni, né tanto meno ad una specifica funzione qualsiasi. Si trova qualcosa in internet riferito per lo più a Excel, sostanzialmente utilizzabile perché non c'è quasi mai differenza tra le funzioni di Excel e quelle di Calc. L'aiuto più immediatamente accessibile è la creazione guidata; io ho imparato di lì, sperimentando le funzioni che man mano mi servivano.

Immagine gravatar per R.C. R.C. ( 2019-10-10 09:48:06 +0200 )modifica

RINGRAZIO PER IL TEMPO CHE MI DEDICHI Da quello che intuisco dalla tue risposte non posso avere un conteggio dei soli valori univoci che rispecchiano i 2 o 3 criteri impostati con CONTA.PIU.SE al posto di vero o falso. Vero o falso lo posso sostutire con un valore sempre uguiale, mentre io vorrei fa apparire nella cella della funzione il numero variavile del conteggio (dei valori univoci) esempio voce 1, voce 2, voce 2, voce 3, voce 2= 3......(somma dei valori univoci)
io avrei questa funzione =SOMMA(--(FREQUENZA(SE($I$2:$I$75="V";CONFRONTA(A$2:A$75;A$2:A$75;0));RIF.RIGA(A$2:A$75)-RIF.RIGA(A$2)+1)>0)) ma funziona solo ocn 1 criterio e io avrei bisogno di 2 o 3 criteri.... questa l'ho trovata su youtube per funzioni excel.....e funziona ma solo su 1 criterio ...(more)

Immagine gravatar per giuse giuse ( 2019-10-10 11:18:35 +0200 )modifica

Mi viene il dubbio che forse finora abbiamo inteso due cose diverse per "valori univoci": intendi dire "un record Azienda X-Mese 5-Lavoro A-..." che si trova una volta sola nell'elenco? oppure intendi dire "tutti i record riferiti all'Azienda X nel mese 5 per il lavoro A", ottenendone il numero?

Immagine gravatar per R.C. R.C. ( 2019-10-10 12:33:12 +0200 )modifica
0

risposto il 2019-10-08 16:02:08 +0200

Immagine gravatar per akurery
modifica flag offensive delete link more

Commenti

Si da inserire in una cella. L'importante che conti i valori univoci. Con conta se mi ocnta tutti i valori anche doppi, tripli....

Immagine gravatar per giuse giuse ( 2019-10-08 16:37:08 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-10-08 15:55:24 +0200

Seen: 36 times

Last updated: Oct 09