Fai la tua domanda
0

Funzione SE - o altra da adeguata.

chiesto il 2019-10-20 15:13:08 +0100

Immagine gravatar per Doriano

updated 2019-10-20 15:21:41 +0100

Devo confrontare se sussistono determinate condizioni presenti in due celle della stessa riga (per poi ripeterle nelle righe successive). L'esempio è questo: Prima cella A1 (5) - Seconda cella B1 (2) / Inserisco la formula: =SE(A1=5;SE(B1=2;1;"")) restituisce 1. Se invece una delle due celle (A1 o B1) non contiene nessun valore (A1 ad esempio contiene 5 ma B1 è vuota o viceversa) o tutte e due non contengono dati (A1 è vuota e B1 è vuota) restituisce FALSO. Manca qualche parametro e/o si deve utilizzare qualche altra funzione?

modifica retag flag offensive close merge delete

3 Answers

0

risposto il 2019-10-20 15:40:07 +0100

updated 2019-10-20 19:06:12 +0100

Basta la funzione =E(A1=5;B1=2).

Se la mia riposta ti ha aiutato, votala con ✔ (qui a sinistra)

modifica flag offensive delete link more
0

risposto il 2019-10-21 12:59:13 +0100

Immagine gravatar per maci

In alternativa alla soluzione di Charile.it la tua formula va completata così: =SE(A1=5;SE(B1=2;1;"");"")

modifica flag offensive delete link more

Commenti

Questa Funziona. Grazie "maci"

Immagine gravatar per Doriano Doriano ( 2019-10-21 14:08:23 +0100 )modifica

Purtroppo non funziona neppure questa; quando infatti trova uno delle due celle "piena" e una "vuota" segnala #VALORE. Vedasi risposta data a charlie; probabilmente è un problema, come dice Microsoft, di configurazione del sistema operativo (io uso WIN 10) ma non si è risolto come dicono loro.

Immagine gravatar per Doriano Doriano ( 2019-10-21 14:18:48 +0100 )modifica

Sul mio PC funziona correttamente (come anche la seconda di Charlie), con WIN10. Mi viene da pensare che ci sia un problema di formattazione delle celle. Sono tutte formattate come numeri?

Immagine gravatar per maci maci ( 2019-10-21 15:11:35 +0100 )modifica

Le celle da cui si prelevano i numeri e le celle dove sono scritte le formule sono in formato "Numero - Standard".

Immagine gravatar per Doriano Doriano ( 2019-10-21 18:32:14 +0100 )modifica
0

risposto il 2019-10-20 18:49:44 +0100

Immagine gravatar per Doriano

Salve charlie. Purtroppo no, in quanto ho bisogno che il risultato sia "1" oppure cella vuota. In questo modo si ottiene "VERO" o "FALSO". Grazie comunque

modifica flag offensive delete link more

Commenti

Basta modificare: =SE(E(A1=5;B1=2);1;"")

Immagine gravatar per charlie.it charlie.it ( 2019-10-20 19:04:51 +0100 )modifica

Questa da #ERRORE quando trova una o due celle vuote. Avevo letto da qualche parte, su Istruzioni di Office, che era dovuto al sistema Operativo; io ho provato a seguire quello che indica Microsoft ma non funziona lo stesso. Grazie comunque.

Immagine gravatar per Doriano Doriano ( 2019-10-21 14:08:40 +0100 )modifica

Buondì! Forse vale per le macro ma non credo per le formule. Prova ad allegare un file d'esempio col risultato voluto...file .ods intendo...

Immagine gravatar per gioh66 gioh66 ( 2019-10-21 15:10:47 +0100 )modifica

Scusa, ma non è da molto che uso ASK: come faccio ad allegare un file di esempio? Grazie.

Immagine gravatar per Doriano Doriano ( 2019-10-21 18:33:02 +0100 )modifica

Vai al tuo primo messaggio, clicca su modifica, nel pannello sopra c'è un'icona a forma di graffetta, cliccaci sopra e segui la procedura.

Immagine gravatar per gioh66 gioh66 ( 2019-10-21 19:47:25 +0100 )modifica

Grazie a tutti. Ho risolto; bastava che le celle da dove si leggono i dati fossero "0" e non "vuote" (come le avevo lasciate io) e funziona perfettamente. Adesso "oscurerò" le celle con "0" in modo da non vedere una marea di dati (sono circa 2000 righe con 7 celle cadauna).

Immagine gravatar per Doriano Doriano ( 2019-10-22 13:26:12 +0100 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2019-10-20 15:13:08 +0100

Seen: 38 times

Last updated: Oct 21