Fai la tua domanda
0

Riprendere il contenuto di una cella in una formula

chiesto il 2020-07-09 21:00:52 +0200

Immagine gravatar per Marzio

Buongiorno, ho un file Calc con diversi fogli chiamati "Riassunto", "Caso1", "Caso2", ecc. Vorrei che nel foglio "Riassunto" vengano ripresi dei valori presenti nei fogli "Caso1", "Caso2", ecc.

La formula per riprendere il valore della cella C24 nel foglio caso 1 sarebbe: =$Caso1.C24

Nella cella A1 del foglio Riassunto scrivo Caso1. Vorrei fare in modo che nella formula non debba scrivere $Caso1.C24, ma che mi riprenda il testo della casella A1, in maniera che, ad esempio, se cambiassi il valore nella casella A1 in Caso2, mi verrebbe restituito non più la cella C24 nel foglio Caso1, bensì la cella C24 nel foglio Caso2.

Grazie.

modifica retag flag offensive close merge delete

1 Answer

0

risposto il 2020-07-10 09:02:22 +0200

Immagine gravatar per gioh66

Buondì. Se ho capito lo puoi fare con una cella d'appoggio in cui inserisci una convalida dei vati (validità) con i nomi dei fogli (io ho usato la cella B1). Poi in A1 del foglio riepilogo metti la formula =INDIRETTO("'"&B1&"'.C24") Cambiando il valore in B1 andrà a pescare il risultato della cella C24 del foglio indicato. Allego esempio. Ps.: un consiglio: quando dai i nomi ai fogli non lasciare spazi tra le parole ma usa per separarle il trattino basso "_"C:\fakepath\Riassunto.ods

modifica flag offensive delete link more

Commenti

Buongiorno. Esattamente. Ora però ho bisogno che se trascino, ad esempio verso destra, non mi dia più il contenuto di C24, bensì di C25 (sempre nello stesso foglio). È possibile? Grazie mille.

Immagine gravatar per Marzio Marzio ( 2020-07-10 09:21:50 +0200 )modifica

Puoi fare così: sposta il menù a tendina in un'altra cella (io l'ho messo in A3) e in A1 metti

=INDICE(INDIRETTO("'"&$A$3&"'!C24:C100");RIF.COLONNA(A1))&""

e tira a destra. Se il tuo intervallo di valori aumenta il 100 col numero di cella che ritieni più opportuno.

Immagine gravatar per gioh66 gioh66 ( 2020-07-10 11:31:06 +0200 )modifica

Grazie mille. Funziona verso destra (e anche verso sinistra). È possibile anche verso il basso? (trascinando resta uguale).

Immagine gravatar per Marzio Marzio ( 2020-07-10 13:19:43 +0200 )modifica

Si però per non avere problemi metti il menù a tendina in A1 e in A2 metti

=INDICE(INDIRETTO("'"&$A$1&"'!C24:C100");RIF.RIGA(A1))&""

e trascini in basso. Se invece vuoi i dati di una tabella, ad esempio C24:E100, metti

=INDICE(INDIRETTO("'"&$A$1&"'!C24:E100");RIF.COLONNA(A1);RIF.COLONNA(A1))&""

e trascini a destra e in basso

Immagine gravatar per gioh66 gioh66 ( 2020-07-10 14:42:53 +0200 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2020-07-09 21:00:52 +0200

Seen: 31 times

Last updated: Jul 10