Fai la tua domanda
0

BASE - problema di crash periodico e perdita dati

chiesto il 2016-04-17 12:41:23 +0100

Immagine gravatar per daniele10

Utilizzo un piccolo database (7 tabelle: clienti, documenti, chiamate, ecc) in un piccolo ufficio (2 persone), il file è salvato su un hard disk di rete ed utilizzato al 99% da un solo utente (1% da due utenti).

Periodicamente quando si apre il file, che fino al giorno prima funzionava regolarmente, si verifica un problema del tipo: "database corrotto" o qualcosa di simile.

In sintesi non è possibile accedere al database e il file risulta irrecuparabile, le dimensioni del file "guasto" risultano nettamente inferiori rispetto al file originale (5MB). Per risolvere il problema devo ricaricare l'ultima copia di backup perdendo i dati inseriti nel frattempo.

Il problema si presenta periodicamente (3-6mesi) da un paio di anni, nel frattempo abbiamo:

  • aggiornato periodicamente le versioni di Libre Office (scegliendo sempre "Still");
  • sostituito l'hard disk di rete.

Versione libre office utilizzata attualmente: 5.0.5.2; Windows 10 su tutti i PC (2)

Non sono riuscito a capire la natura del propblema e la soluzione, sono grato per qualsiasi aiuto per risolvere o identificare il problema.

modifica retag flag offensive close merge delete

2 Answers

0

risposto il 2016-04-17 17:56:31 +0100

Ciao, al livello desktop, di solito il problema si risolve con il reset del profilo utente. E' la cartella dove sono memorizzate le impostazioni e dove si trovano i backup. Non sono sicuro che sia la soluzione nel tuo caso ma si può sempre provare: https://ask.libreoffice.org/en/questi...

Ti consiglio salvataggi manuali frequenti oltre a quelli automatici che di default sono ogni 15 minuti.

Se la mia riposta ti ha aiutato, votala con ✔ e con ∧ (qui a sinistra)

modifica flag offensive delete link more

Commenti

fatto. ora vediamo se il problema si ripete (speriamo di no)

Immagine gravatar per daniele10 daniele10 ( 2016-04-18 15:15:03 +0100 )modifica
0

risposto il 2016-09-13 12:43:01 +0100

Immagine gravatar per daniele10

Purtroppo il problema si ripropone dopo aver aggiornato alla versione: 5.1.5.2

Questa volta le dimensioni del file "guasto" risultano nettamente superiori rispetto al file originale (5MB) Ho eseguito il reset del profilo utente ma il problema persiste.

MI piacerebbe trovare un soluzione anche a costo di utilizzare "altri database", ho bisogno di qualcosa semplice ma assolutamente affidabile. Ringrazio anticipatamente chiunque mi possa essere di aiuto.

modifica flag offensive delete link more

Commenti

Era necessario aggiornare? A volte una versione software datata ma stabile è preferibile.

Immagine gravatar per charlie.it charlie.it ( 2016-09-13 13:55:37 +0100 )modifica

Bella domanda ;-) in effetti mi chiedo spesso se e quando aggiornare. In questo caso non è che prima non si bloccava mai, in effetti lo faceva "ogni tanto", la speranza è stata: "aggiorno con una versione 'stabile' e magari il problema è stato risolto". Purtroppo la situazione è peggiorata.

Ora ho appena provato ad installare la Versione: 5.2.1.2 dato che la precedente era inservibile per Base.

Immagine gravatar per daniele10 daniele10 ( 2016-09-13 17:47:38 +0100 )modifica

Non dimenticare di resettare il profilo utente con una nuova installazione, altrimenti ti ritrovi quello della versione precedente.

Immagine gravatar per charlie.it charlie.it ( 2016-09-13 23:07:34 +0100 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2016-04-17 12:41:23 +0100

Seen: 584 times

Last updated: Sep 13 '16