Fai la tua domanda
0

estrapolare dati da un secondo foglio o file in base ad una cella modificabile

chiesto il 2017-01-10 16:13:39 +0100

Immagine gravatar per Coguaro

io avrei bisogno da un file di calc in cui inserisco un numero in una cella che in altre due celle mi esca il nominativo e cellulare corrispondente presi o da un secondo foglio nello stesso file o preferibilmente da un'altro file ho provato con la funzione cerca usando questo codice=CERCA(C9;Foglio2.A2:A15000;Foglio2.K2:K15000) in cui c9 è la cella in cui metto il numero io A2:A15000 è l'intervallo di celle nel secondo foglio in cui cercare il numero messo nella cella c9 e K2:K15000 è l'intervallalo di celle sempre nel secondo foglio dove estrarre la cella corrispettiva alla cella trovata nel primo intervallo di celle

almeno così è come ho capito io che dovrebbe funzionare è giusto o ho capito male io come funziona?

modifica retag flag offensive close merge delete

1 Answer

0

risposto il 2017-01-11 23:27:13 +0100

Immagine gravatar per akurery

La formula inserita è corretta infatti a me funziona, tieni però presente che la funzione CERCA richiede che i valori nella colonna (o riga) su cui viene effettuata la ricerca siano ordinati.
Verifica anche che i valori nella cella C9 e nella colonna A2:A15000 siano nello stesso formato.
In alternativa puoi usare la funzione CERCA.VERT, che nel tuo esempio andrebbe inserita come =CERCA.VERT(C9;Foglio2.A2:K15000;11). In pratica nei parametri avresti in C9 il valore da cercare, A2:K15000 indica l'intera tabella dei valori, 11 è la colonna da restituire (la colonna K è l'undicesima), Questa funzione effettua la ricerca solo sulla prima colonna della tabella, ma i valori possono essere anche non ordinati.

modifica flag offensive delete link more

Commenti

in effetti a me dava errore perché non erano formattate correttamente

Immagine gravatar per Coguaro Coguaro ( 2017-01-17 14:22:50 +0100 )modifica
Login/Signup to Answer

Question Tools

1 follower

Stats

Chieste: 2017-01-10 16:13:39 +0100

Seen: 86 times

Last updated: Jan 11 '17