質問する
0

LibreOfficeで使用できるJava実行環境は?

質問日 2019-01-04 06:46:54 +0200

kitirou110.2@gmail.com のGravatar画像

updated 2019-01-15 04:26:29 +0200

nogajun のGravatar画像

皆様

お世話になっております。ShibataKと申します。

会社でLibreOfficeを使用しており、一部の機能でJREを使用するため、JREをインストールしています(Clinet:Windows10)。

今後JREは有償化されるので、有償化されないようにOpenJDKなどを使用できたら良いなと思っていますが、他の無償で使用できるJava実行環境をご存知のかたはいらっしゃいますでしょうか。 ご教授頂きたく、お力添えお願い致します。

edit retag flag offensive close merge delete

1 Answer

1

回答日 2019-01-24 01:22:55 +0200

himajin100000 のGravatar画像

updated 2019-01-24 01:23:35 +0200

java.vendorの値が

https://opengrok.libreoffice.org/xref...

https://opengrok.libreoffice.org/xref...

ココに載っているものになっているときは手動でbinとlibフォルダを含むフォルダを手動で指定してあげれば、大抵大丈夫です。

ただ、AdoptOpenJdkの値は最近俺が足したもの( https://gerrit.libreoffice.org/#/c/66... ) で、それが6.2系と6.1系に採用されたので、6.2系、6.1系共に「次のリリース・RC版から」使えます。

また、AdoptOpenJdkの値になっているのは、回答時点でAdoptOpenJDKv8のみで、v9以降は値がOracle Corporationになっています。今後のバージョンでv9以降にも同様の修正が入るものと予測されます。現状ではv8のみ認識しないということですね。

Amazon Corettoについて調べたところ、Preview2の段階ではこの値はOracle Corporationなので、普通に認識されますが、リリース版までにこの値が修正された場合(こちらの追加は俺はやってないので)、動かなくなるかもしれません

あ、困ったことに環境変数PATHが通っているとトラブルが起きることがあります。

edit flag offensive delete link もっと

Comments

Mergeされたため、英語版ページ等でダウンロードできる8u202版Amazon Correttoも6.3系で認識されるようになりました。まぁ6.2系や6.1系にも、このパッチが当たるようになると思いますけどね。

himajin100000 のGravatar画像himajin100000 ( 2019-02-04 11:51:22 +0200 )edit

上記バグレポの通り、6.2.3から、Amazon Correttoにも対応してます。

https://gerrit.libreoffice.org/#/c/69...

himajin100000 のGravatar画像himajin100000 ( 2019-03-31 05:01:25 +0200 )edit
ログイン/サインアップして回答する

質問ツール

1 follower

Stats

Asked: 2019-01-04 06:46:54 +0200

Seen: 1,058 times

Last updated: Jan 24