Stel uw vraag
1

Spellingscontrole Libre Writer werkt niet meer

gevraagd 2021-01-10 18:56:56 +0200

mjammie gravatar image

updated 2021-01-11 13:19:28 +0200

Beste fans van Libre Office,

Sinds korte tijd is me opgevallen dat de spellingscontrole niet meer werkt. Ik zou niet weten wat er eventueel mis mee is. De spellingscontrole, tweede optie in het menu Extra, staat aan. Ook handmatig controleren met de eerste optie Spelling in het menu Extra geeft geen enkel resultaat, wat niet kan en klopt door zelfgemaakte spellingsfouten. Onder Extra - Spelling - Opties staan spelling en grammatica controleren tijdens typen aan. Tot voor kort heeft de spellingscontrole het ook altijd gewoon gedaan. Is er ergens een andere instelling die dit kan verklaren?

Om het zelf proberen op te lossen heb ik eerst het installatieprogramma 7.0.3 laten lopen met optie repareren. Ook heb ik de nieuwe versie 7.0.4 geïnstalleerd. Beiden zonder resultaat.

Graag jullie hulp, want ik wil natuurlijk geen brieven versturen met spellingsvauten, dan loop je het risico dat je een stuk minder zere neus wordt genomen. Alvast bedankt!

MjammieC:\fakepath\Libre test document spellingscontrole.docx

bewerken retag markeer ongewenst sluiten samenvoegen verwijderen

Commentaren

1

Als alles is ingesteld om te werken, dan zijn er twee mogelijkheden: het gebruikersprofiel is naar de vaantjes, of je hebt geen taal ingesteld voor je document. In het laatste geval loopt de spellingcontrole vlot door je document en meldt niks gevonden te hebben. Zie voor het oplossen van problemen met het gebruikersprofiel: http://forum.openoffice.org/nl/forum/... en https://wiki.documentfoundation.org/U... (de vertaling daarvan zit in de spreekwoordelijke pijplijn).

floris v gravatar imagefloris v ( 2021-01-10 20:37:14 +0200 )bewerken

Beste Floris,

Ik wist wel dat ik op jou zou kunnen rekenen voor hulp!

Ik heb er verder nog niet naar gekeken, maar ik krijg in ieder geval geen melding dat er niets is gevonden. Ook lijkt de taal gewoon goed ingesteld. Hoe en waar kan ik dit zien? Wel heb ik laatst wat met sjablonen lopen te kloten en daarbij ook een aantal sjablonen die ik dacht dubbel te hebben of overbodig verwijderd. Wellicht ben ik daarbij wat al te enthousiast te werk gegaan. Ook zag ik bij het openen van een nieuw document dat het ingestelde lettertype was vervangen door het standaard lettertype. Dit lijkt dan toch te wijzen op het gebruikersprofiel. Ik had zelf al een vermoeden dat het hiermee te maken zou kunnen hebben.

Een oplossing kan natuurlijk ook zijn om Libre eerst helemaal te verwijderen en daarna opnieuw te installeren. Want dit heb ik voor ...(more)

mjammie gravatar imagemjammie ( 2021-01-10 22:08:15 +0200 )bewerken

Kun je een voorbeeldbestand uploaden? Je kunt dat als bijlage toevoegen in je vraag, druk daaronder op bewerken en voeg dan je bestand toe. Opnieuw installeren van LO is tijdverspilling, dat helpt hier niet.

floris v gravatar imagefloris v ( 2021-01-10 22:45:11 +0200 )bewerken

Je kunt ook een kijkje nemen op https://forum.openoffice.org/nl/forum.... Maar bijna altijd ligt het aan het gebruikersprofiel.

floris v gravatar imagefloris v ( 2021-01-11 00:09:55 +0200 )bewerken

Floris,

Dank voor je links, heel nuttig!

Ik begrijp niet goed wat je met een bestand van mij wilt of kunt. Als je dit opent op jouw computer doe je dit met je eigen versie van Libre en zul je mijn gemaakte aanpassingen niet kunnen zien. Of zie ik dit verkeerd en worden die opgeslagen in het bestand?

Hoe dan ook denk ik dat voor mij nu de snelste oplossing gewoon is om Libre te verwijderen, de laptop opnieuw opstarten en daarna de nieuwe versie van Libre opnieuw te installeren. Mee eens?

Dus ik ben hoe dan ook blij met je diagnose van het probleem. Je verwijzingen voor verdere informatie bewaar ik dan voor later. Hopelijk heb ik je hiermee niet tegen het hoofd gestoten, ik begrijp dat je graag je kennis wilt delen.

Mjammie

mjammie gravatar imagemjammie ( 2021-01-11 01:44:55 +0200 )bewerken
1

Als je LibreOffice verwijdert blijft je gebruikersprofiel behouden. De kans is groot dat als je LO weer installeert, dat het probleem blijft. Je kan eerst je profiel proberen te herstellen. Ga naar Help - Opnieuw opstarten in veilige modus. Kies dan voor Fabrieksinstellingen herstellen en Gehele profiel herstellen. Je bent dan wel al je aanpassingen kwijt.

Kees538 gravatar imageKees538 ( 2021-01-11 09:17:02 +0200 )bewerken

@mjammie: Ik ga ervan uit dat je het probleem met al je documenten hebt. Maak een nieuw document, zet daarin wat willekeurige tekst met minstens een spelfout of plak er een stuk van deze discussie in. Zet dat hier als bijlage in je vraag. Ik en/of Kees kan dan zien of bv de taal goed is ingesteld. Het kan bv zijn dat je geen woordenboek voor Nederlands hebt. Heb je eigen aanpassingen in je gebruikersprofiel?

floris v gravatar imagefloris v ( 2021-01-11 10:04:50 +0200 )bewerken

In het document Gebruikersprofiel via de link van Floris (https://wiki.documentfoundation.org/U...) staat inderdaad:

Het "gebruikersprofiel" is de map waarin alle gegevens die betrekking hebben op de gebruiker, zoals extensies, aangepaste woordenboeken, sjablonen enzovoorts staan. Deze map wordt niet verwijderd bij de-installeren of updaten van LibreOffice, zodat je aanpassingen bewaard blijven.

mjammie gravatar imagemjammie ( 2021-01-11 16:09:37 +0200 )bewerken

Floris,

Ik heb inmiddels een nieuw gebruikersprofiel aangemaakt met jouw turorial. De mogelijkheid om oude configuratiebestanden terug te kunnen zetten is bij mij echter helaas niet naar boven gekomen. Als je nog een manier weet om die alsnog terug te halen verneem ik dit graag.

mjammie gravatar imagemjammie ( 2021-01-11 19:12:59 +0200 )bewerken

Beste Floris en Kees,

ik heb alles wat ik via jullie en zelf heb gevonden bij elkaar gezet in Zelf beantwoorden eigen vraag. Uiteraard met verwijzing naar jullie! Kan ik jullie nog ergens punten geven voor jullie bijdragen?

Mjammie

mjammie gravatar imagemjammie ( 2021-01-11 19:20:53 +0200 )bewerken

3 Antwoorden

1

beantwoord 2021-01-11 14:18:10 +0200

floris v gravatar image

updated 2021-01-11 22:37:02 +0200

Bestand geopend in LibreOffice 7.0.3.1 (gedownload vanaf de site, niet de versie die Ubuntu levert), spelfouten worden getoond. Ook geopend in LO 7.0.2.2 (die heeft zichzelf geïnstalleerd - :( ), spelfouten worden niet getoond. Dus: versie 7.0.2.2 heeft bij mij hetzelfde probleem. Er staat in die versie geen vinkje bij Nederlands in de lijst met talen, in versie 7.0.3.1 wel. Daar zit dus (bij mij) het probleem. En bij jou denk ik ook.

Inmiddels heb ik 7.0.2.2 eraf gegooid, dat is trouwens de versie die door Ubuntu Linux wordt meegeleverd. Advies: in Linux altijd de officiële versie van LibreOffice installeren, die is beter.

bewerken markeer ongewenst verwijderen link meer

Commentaren

Floris,

Ik was net al bezig met het doornemen van je aangereikte stukken in de hyperlinks. Het is goed van je dat je een mogelijke oorzaak hebt kunnen vinden. Maar zoals eerder aangegeven heb ik nu de laatste versie 7.0.4.2. geïnstalleerd. Waar vind ik die lijst met talen? In menu Extra – Taal – voor gehele tekst – staat Nederlands bovenaan. Die heb ik al veelvuldig geselecteerd, maar dan verschijnt er geen vinkje of net als bij het aanklikken van spellingscontrole een blauw achtergrondvierkantje.

mjammie gravatar imagemjammie ( 2021-01-11 15:35:12 +0200 )bewerken

Onder Extra – Opties – Taalinstellingen – Talen (ook te bereiken via Extra – Taal – voor gehele tekst – Meer staat overal standaard – Nederlands. Achter het pijltje van Lokale instellingen en Westerse staat de waslijst aan talen.

mjammie gravatar imagemjammie ( 2021-01-11 15:53:47 +0200 )bewerken

Je kunt in het opmaakprofiel Standaard op de tab Font de taal instellen (heel logisch, maar ze konden er geen andere plek voor vinden, neem ik aan). In die afrollijst staan vinkjes voor alle talen waarvoor een woordenboek geïnstalleerd is. Geen vinkje betekent: geen woordenboek. Ga dus je gebruikersprofiel maar vernieuwen, als je dat nog niet gedaan had.

floris v gravatar imagefloris v ( 2021-01-11 16:24:12 +0200 )bewerken

In hetzelfde document staat ook hoe je kunt nagaan of het probleem inderdaad aan het gebruikersprofiel ligt. Dit doe je door Libre op te starten in de veilige modus via Help – opnieuw opstarten in veilige modus. Klik vervolgens onderaan op: in veilige modus doorgaan.

Ik heb dat inderdaad gedaan en het probleem van de niet meer werkende spellingscontrole is opgelost. Wanneer ik daarna de veilige modus afsluit is het probleem weer back. Conclusie: er is dus blijkbaar iets mis met mijn gebruikersprofiel! Gelukkig staat in hetzelfde document ook hoe je dit vervolgens kunt oplossen.

mjammie gravatar imagemjammie ( 2021-01-11 16:47:38 +0200 )bewerken

Floris,

Daar moet ik je toch corrigeren helaas. Dit lijkt niet te kloppen. Op de door jou aangegeven plaats kun je de standaard taal niet wijzigen, dus ook niet selecteren. Want kies je een andere taal, dan verandert de standaard taal niet. Je kunt de taal voor documenten in een andere taal voor bijvoorbeeld spellingscontrole wel (tijdelijk) aanpassen via Extra – Opties – Talen – Standaardtalen voor documenten. Ik vermoed dat je de standaardtaal bij het installeren van Libre ofwel kiest uit de waslijst aan talen wanneer je niet kiest voor Standaard, maar voor Aanpassen. Kies je Standaard, dan zal Libre automatisch herkennen in welk land je bent via je IP-adres of zo. Zoek je op Libre Office dan kom je ook meteen in de Nederlandstalige website terecht. Daarna ligt die vervolgens vast en is niet meer te wijzigen en waarom zou je ook? Dit is de taal van het land waar je ...(plus)

mjammie gravatar imagemjammie ( 2021-01-11 17:34:11 +0200 )bewerken

Het gaat er niet om dat je de standaardtaal wijzigt. Je kunt in één document verschillende talen door elkaar gebruiken. Je moet voor al die talen wel woordenboeken hebben om wat aan de spellingcontrole te hebben. Bovendien herkent LibreOffice de taal waarin je schrijft niet, dus je moet Nederlandse tekst opmaken als Nederlands en Engelse als Engels.

floris v gravatar imagefloris v ( 2021-01-11 17:43:35 +0200 )bewerken
0

beantwoord 2021-01-11 19:14:10 +0200

mjammie gravatar image

updated 2021-01-11 21:01:33 +0200

Met dank aan Floris aan Kees538, zie hun commentaren! Voor het gemak van andere gebruikers heb ik het antwoord hier weergegeven zodat ze dit niet zelf hoeven te zoeken door alle commentaren door te nemen.

Ik heb inmiddels het gebruikersprofiel vernieuwd via de handleiding Gebruikersprofiel Libre Office (https://wiki.documentfoundation.org/U...) of de tutorial van Floris (https://forum.openoffice.org/nl/forum...). Het enige dat je hoeft te doen is Libre Office helemaal afsluiten en naar de map users te gaan in Verkenner. In Windows 10 vind je die hier: lokale schijf (C:) – Gebruikers – je eigen gebruikersnaam – AppData – Roaming – LibreOffice – 3 of 4 (versienummer LibreOffice) – user. Verander user in een andere naam, bijvoorbeeld user oud. Vervolgens LibreOffice weer opstarten en het probleem is als het goed verholpen. Zo niet, dan ligt het probleem niet bij het gebruikersprofiel. Dit kun je zoals je kunt vinden in Gebruikersprofiel Libre Office makkelijk testen door Libre Office in de veilige modus te starten via Help – opnieuw opstarten in veilige modus. Wel eerst alle geopende documenten opslaan! Klik vervolgens in de verschenen pop-up onderaan op: in veilige modus doorgaan. Doet het probleem zich nu niet meer voor, dan lag het dus inderdaad aan het gebruikersprofiel. Zo niet, dan dus niet. Bij mij is het probleem nu opgelost. Omdat het gebruikersprofiel is vernieuwd ben je helaas wel ook alle zelf aangebrachte wijzigingen zoals in opmaakprofielen of automatische correcties kwijt. P.S. Volgens het document Gebruikersprofiel Libre Office zal het verwijderen en opnieuw installeren van LibreOffice niet werken omdat het gebruikersprofiel wordt bewaard!

Het zichtbaar maken van verborgen mappen in Verkenner onder Windows 10 doe je als volgt: Ga naar Instellingen – Bijwerken en Beveiliging – Voor ontwikkelaars. Scroll een beetje naar beneden naar Verkenner en zet in ieder geval het tweede vinkje aan bij: Instellingen wijzigen, zodat verborgen bestanden en systeembestanden worden weergegeven. Daarna klikken op Toepassen. Wil je dit weer ongedaan maken, dan ga je naar Instellingen weergeven waarna de pop-up Opties voor verkenner verschijnt (behalve bij de voorlaatste optie). Daar deselecteer je de betreffende optie(s) of kies je voor standaardinstellingen herstellen. Klik op Toepassen en daarna op OK in de pop-up en niet in Instellingen, anders activeer je alle aangevinkte opties. Daarna het Instellingenmenu afsluiten en Verkenner opnieuw opstarten, anders zie je de gemaakte aanpassingen niet!

Voor mogelijke andere oplossingen bij problemen met spellingscontrole, zie https://forum.openoffice.org/nl/forum....

bewerken markeer ongewenst verwijderen link meer

Commentaren

Het vernieuwen van het gebruikersprofiel kan via 'Starten via Veilige modus', zoals Kees melde. Lees hier een uitgebreide beschrijving van de veilige modus.

rwestein gravatar imagerwestein ( 2021-01-12 07:42:01 +0200 )bewerken
0

beantwoord 2021-01-11 09:12:44 +0200

Kees538 gravatar image

Ik heb dit ook soms en het rare is dat er dan geen taal geselecteerd is voor de tekst. Dat klinkt raar, maar dan wordt ook de spelling niet gecontroleerd. Probeer eens het volgende. Ga naar Extra - Taal - Voor alle tekst. En kies dan Nederlands. Wellicht werkt de spellingscontrole dan weer.

bewerken markeer ongewenst verwijderen link meer

Commentaren

Is dat in Windows of Linux? In Apache OpenOffice kun je dit probleem krijgen als je een nieuw OO-document maakt vanuit Windows, door rechtsklikken op de desktop of in een venster van Windows Verkenner en dan Nieuw - Writer-bestand (o.i.d.) te kiezen. Windows koppelt dan een defect standaardsjabloon waarin je geen taal kunt instellen. Ik weet niet of dat in LibreOffice ook zo gat.

floris v gravatar imagefloris v ( 2021-01-11 10:08:42 +0200 )bewerken

Dat is in Windows. Je kunt dan inderdaad de instelling 'Geen taal' hebben. Er wordt dan ook geen spellinscontrole gedaan.

Kees538 gravatar imageKees538 ( 2021-01-11 12:35:14 +0200 )bewerken

Kees,

Die was ik blijkbaar zelf bij mijn zoektocht ook al tegengekomen en daar ligt het zo te zien bij mij niet aan. Er verschijnt overigens geen vinkje of zo bij Nederlands. Ik open een nieuw document altijd vanuit Libre, dus dat kan het ook niet zijn.

Mjammie

mjammie gravatar imagemjammie ( 2021-01-11 15:37:58 +0200 )bewerken

Nederlands staat daar wel, maar je moet het ook echt aanvinken om het te gebruiken.

Kees538 gravatar imageKees538 ( 2021-01-12 07:35:18 +0200 )bewerken

Het probleem is zoals aangegeven inmiddels opgelost door het gebruikersprofiel te vernieuwen. Dit is volgens mij niet op te lossen door zoals jij aangeeft een taal aan te vinken.

Wel kun je zoals aangegeven de taal voor de spellingscontrole voor een document aanpassen in het menu onder Extra – Opties – Taalinstellingen – Talen of Extra – Taal – Voor de gehele tekst – Meer. De taal voor het betreffende document pas je dan aan onder de kop Standaardtalen voor documenten. Die instelling geldt dan alleen voor het betreffende document. Indien dit een andere taal is dan Nederlands zie je die in het menu onder Extra – Taal – Voor gehele tekst de andere geselecteerde taal onder Standaardtalen voor documenten nu bovenaan staan en Nederlands als tweede. Er moet dan wel een woordenboek aanwezig zijn. Die kun je bij installatie aanvinken en misschien ook nadien nog toevoegen. Want anders werkt het natuurlijk niet.

mjammie gravatar imagemjammie ( 2021-01-12 13:40:27 +0200 )bewerken

Met alle respect, maar nu praten we wel totaal langs elkaar heen.

floris v gravatar imagefloris v ( 2021-01-12 14:33:33 +0200 )bewerken

Nog een laatste opmerking over de taalinstelling. Dat het niet hieraan lag heb ik getest door Libre te openen in de veilige modus en het probleem van de spellingscontrole deed zich nu niet voor. In het aangehaalde document Gebruikersprofiel Libre Office staat te lezen: Als het probleem is opgelost, is er iets mis met je configuratie. De oplossing is dan om het gebruikersprofiel te resetten. Hoe je dat doet staat in mijn antwoord.

Ik sluit me bij Floris aan en wil het graag voor nu hierbij laten.

mjammie gravatar imagemjammie ( 2021-01-12 15:40:59 +0200 )bewerken

In mijn nu verwijderde versie van Libre was het Nederlandse woordenboek niet geïnstalleerd en dat lag niet aan het gebruikersprofiel. Dus... daar ligt het niet altijd aan.

floris v gravatar imagefloris v ( 2021-01-12 15:52:16 +0200 )bewerken

Nou vooruit, de allerlaatste opmerking dan. In het door jou beschreven geval zou dit hoogstwaarschijnlijk naar voren zijn gekomen door Libre in de veilige modus op te starten. Ook dan zou de spellingscontrole het niet hebben gedaan en dus de conclusie volgens het document Gebruikersprofiel Libre Office zijn: Als het probleem er nog is, kun je de safe mode verlaten omdat het gebruikersprofiel niet de oorzaak van het probleem was. Bij mij deed de spellingscontrole het dus wel weer in de veilige modus en was derhalve de conclusie: Als het probleem is opgelost, is er iets mis met je configuratie.

mjammie gravatar imagemjammie ( 2021-01-12 17:19:29 +0200 )bewerken

Slotwoord.

Kees,

Je zou nog naar het door Floris verwezen document Probleemoplossing spellingscontrole kunnen kijken of je daar wellicht kunt vinden hoe en waarom de oplossing die jij hebt toegepast bij jou wel werkte.

Tenslotte wil ik jou en Floris nogmaals danken voor jullie hulp waardoor ik nu weer de beschikking heb over de spellingscontrole!

Mjammie

mjammie gravatar imagemjammie ( 2021-01-12 22:41:10 +0200 )bewerken
Login/Registreer om te beantwoorden

Hulpmiddelen Vragen

1 volger

Statistieken

Gevraagd: 2021-01-10 18:56:56 +0200

Bekeken: 83 keer

Laatst bijgewertkt: Jan 11