Pergunte aqui
1

automação em planilha

perguntadas 2017-08-08 22:51:39 +0100

imagem do gravatar de thiago_thigf

updated 2017-08-20 15:29:57 +0100

imagem do gravatar de Grafeno

Descrição da imagem

Olá, estou tentando fazer uma fórmula que me traga o nome da pessoa automaticamente, de acordo com os dias. Conforme a imagem.

Já tentei várias formas e não tive sucesso.

Alguém pode me ajudar???

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

3 Respostas

1

respondidas 2017-08-10 03:44:51 +0100

updated 2017-08-27 22:44:03 +0100

Ola @thiago_thigf, opção de solução como postado:

Criando áreas nomeadas :

Descrição da imagem

E a fórmula usando as funções: ÍNDICE e CORRESP na célula H2 e copiando para as linhas necessárias.

Descrição da imagem


=SE.É.NÃO.DISP((SE.É.NÃO.DISP((SE.É.NÃO.DISP((SE.É.NÃO.DISP((ÍNDICE(areaa;CORRESP(G2;data1;0);1));ÍNDICE(areaa;CORRESP(G2;data2;0);1)));ÍNDICE(areaa;CORRESP(G2;data3;0);1)));ÍNDICE(areaa;CORRESP(G2;data4;0);1)));"-")


>----> Arquivo teste

Obs: Se houver inclusão de novas colunas para data (ex: data5), a fórmula deve ser ampliada/corrigida.

editar assinalar como ofensivo Excluir Link mais

Comentários

Obrigado pelas resposta a todos que responderam, vou tentar de todas essas formas pra ver se consigo fazer.

imagem do gravatar de thiago_thigfthiago_thigf ( 2017-08-11 19:16:13 +0100 )editar

Boa tarde, funciona, mas como vc faria para ampliar sua fórmula de modo a usar uma planilhas com umas 4mil colunas? Não criaria 4mil áreas nomeadas?

imagem do gravatar de thiago_thigfthiago_thigf ( 2017-08-26 22:16:33 +0100 )editar

4 mil Colunas @thiago_thigf, desta maneira não faria, não haveria espaço suficiente para a formula... mas pintou uma ideia, vou tentar e te dou o retorno. Como esta planilha é alimentada com os dados? Dia a dia ou partiu de algum relatório?

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2017-08-27 20:00:06 +0100 )editar
0

respondidas 2017-08-08 23:06:43 +0100

imagem do gravatar de Beto

use a função =SE(), algo como: =SE(B2=G2;A2)

editar assinalar como ofensivo Excluir Link mais

Comentários

para 200 datas ficaria inviável

imagem do gravatar de thiago_thigfthiago_thigf ( 2017-08-08 23:32:38 +0100 )editar

Por quê? Basta fazer a primeira e arrastar a fórmula, faz-se em 30 segundos. Mas se quiser detalhar melhor o funcionamento esperado do seu arquivo podem surgir muitas sugestões, de outros colegas também. Quanto mais detalhes tiver sobre o que você quer fazer, sempre terá um "crânio" entre os colegas que disposto a dar umas dicas.

imagem do gravatar de BetoBeto ( 2017-08-09 13:40:04 +0100 )editar

Veja também este vídeo pode ser que esteja no rumo de alguma coisa que você queira. Tipo escolher uma opção e automaticamente aparecer várias sugestões de preenchimento...

imagem do gravatar de BetoBeto ( 2017-08-09 13:48:04 +0100 )editar

Eu entendi que para cada dia há um único funcionário alocado. E o nome do do funcionário tem de ser tomado da coluna A em função da data nas colunas à direita. Minha abordagem seria por uma combinação de funções PROC. Porém não havendo ordenamento na matriz de datas, complica.

imagem do gravatar de OlivierOlivier ( 2017-08-09 14:11:02 +0100 )editar

Boa tarde, é isso que o Olivier escreveu que eu quero fazer. Beto, sobre o vídeo que vc recomendou, pode repassar o link? não estou conseguindo acessar. Obrigado

imagem do gravatar de thiago_thigfthiago_thigf ( 2017-08-09 18:11:54 +0100 )editar

O vídeo é este aqui, mas não tenho mais certeza que possa te ajudar.

imagem do gravatar de BetoBeto ( 2017-08-09 19:59:11 +0100 )editar
0

respondidas 2017-08-09 20:23:43 +0100

imagem do gravatar de Olivier

Então... só por fórmula eu não sei se é pratico. Mas se os dados pudessem ser rearrumados, eu tenho a solução. Em resumo: tenha uma só coluna de nomes (mesmo repetindo os nomes) e uma coluna de datas. Ordene crescente por datas que a solução é imediata.

Por exemplo, na planilha com dados fictícios abaixo os dados de datas foram empilhados

Descrição da imagem

e na planiha com a coluna Data1 ordenada fica:

Descrição da imagem

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2017-08-08 22:51:39 +0100

Lidas: 72 vezes

Última atualização: Aug 27