Pergunte aqui
1

Referenciar com valor de célula.

perguntadas 2018-03-24 14:47:00 +0200

imagem do gravatar de joaopvgus

updated 2018-03-30 00:37:46 +0200

imagem do gravatar de Olivier

Bom dia, estou precisando referenciar dentro de uma célula determinada planilha, porém, gostaria de ao invés de colocar entre apóstrofos o diretório do arquivo, colocar uma fórmula ou algo do tipo que regatasse o diretório (escrito sozinho numa fórmula). Ex.: tenho

=SE(A2="";"";PROCV(A2;'file:///C:/Users/Amusical/Desktop/Teste/Estoque.ods'#$Planilha1.A1:B200;2;0))

e gostaria que ficasse algo como

=SE(A2="";"";PROCV(A2;C3.A1:B200;2;0))

sendo que em C3, o valor seria

'file:///C:/Users/Amusical/Desktop/Teste/Estoque.ods'#$Planilha1

Tem como fazer isso?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

1

respondidas 2018-03-24 16:12:30 +0200

imagem do gravatar de Grafeno

Boa tarde,

Ou seja, transformar um texto em uma referência reconhecida pelo Calc.

Justamente o que a função INDIRETO() faz:

=SE(A2="";"";PROCV(A2;INDIRETO(C3&".A1:B200");2;0))

Ate,

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-03-24 14:47:00 +0200

Lidas: 38 vezes

Última atualização: Mar 30 '18