Pergunte aqui
0

Marcar produtos baseado no cupom

perguntadas 2018-05-06 05:27:43 +0200

imagem do gravatar de Aldo

updated 2018-05-06 05:48:25 +0200

Boa noite, tenho um arquivo com duas planilhas. A primeira planilha contém duas colunas (com dados verticais): Cupom e Produto e na segunda contem a coluna cupom e nome dos produtos (com dados horizontais), já que apliquei remover dados duplicados na primeira planilha e colei esses dados na segunda planilha. Exemplificando:

Planilha 1

Acima planilha 1

Descrição da imagem

Acima planilha 2

O que queria fazer é mostrado na planilha 2, onde teria uma fórmula que leria a coluna cupom da planilha 1 baseado na planilha 2 e veria quais produtos existem (baseado também no nome de cada produto) e marcaria elas com sim ou true na planilha 2 (No exemplo da planilha dois leu os produtos algodao, bala e esponja e marcou sim). Alguém pode me ajudar? Já tentei fazer com procv (=PROCV(A2;$dados.A2:$C$245000;3;1)), mas não chegou nem perto.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

0

respondidas 2018-05-06 16:18:09 +0200

Bem vindo @Aldo, tendo como base os dados abaixo,

Descrição da imagem

segue a fórmula: =SE(CONT.SES($Planilha1.$A$2:$A$12;$A2;Planilha1.$B$2:$B$12;B$1)>0;"SIM";"")

Descrição da imagem

O arquivo teste aqui....

Obs.: Se incluir uma nova coluna com valor 1 em todos os itens, é possível gerar o Resumo com Tabela Dinâmica, mas em lugar do SIM mostra a quantidade de 1s, e só produtos que venderam.

Arquivo teste modificado aqui....


Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Muitíssimo obrigado @gilberto-schiavinatto, era exatamente disso que eu precisava.

imagem do gravatar de AldoAldo ( 2018-05-06 22:56:28 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-05-06 05:27:43 +0200

Lidas: 20 vezes

Última atualização: May 06