Pergunte aqui
0

Função "SE" tem limite de critérios?

perguntadas 2018-05-10 14:54:57 +0200

imagem do gravatar de Camilla Vieira

Estou tentando montar a seguinte fórmula:

=SE(E(C7=100%);"Concluído";SE(E(C7<18%);"Estudo Inicial";SE(E(C7<46%);"Reuniões";SE(E(C7<79%);"Minuta";SE(E(C7<100%);"Etapa final";SE(E(C7=0);"Iniciar";"--"))))))

Porém o último critério, "inciar", não está ocorrendo, sendo que quando a célula fica com "0", está se enquadrando no critério: "Estudo Inicial)..

Já troquei de posição o critério e ele funcionou, porém perdeu o critério "Minuta". Dá a impressão que existe limite de critérios.... Com proceder nesse caso?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Acabei de descobrir o problema, o critério com o%, tem que estar no começo, por ser o menor valor, dentre os critérios... Porém ainda quero saber, se existe limite de critérios para essa função.

imagem do gravatar de Camilla VieiraCamilla Vieira ( 2018-05-10 15:22:04 +0200 )editar
1

Apliquei 20 funções "SE" conforme abaixo, e funcionou perfeitamente.

=SE(A1=1;A1;SE(A1=2;A1;SE(A1=3;A1;SE(A1=4;A1;SE(A1=5;A1;SE(A1=6;A1;SE(A1=7;A1;SE(A1=8;A1;SE(A1=9;A1;SE(A1=10;A1;SE(A1=11;A1;SE(A1=12;A1;SE(A1=13;A1;SE(A1=14;A1;SE(A1=15;A1;SE(A1=16;A1;SE(A1=17;A1;SE(A1=18;A1;SE(A1=19;A1;SE(A1=20;A1;"ERRO"))))))))))))))))))))

imagem do gravatar de ConradoConrado ( 2018-05-10 22:16:32 +0200 )editar

hahaha então funciona com bem mais que cinco.

imagem do gravatar de Camilla VieiraCamilla Vieira ( 2018-05-11 14:09:31 +0200 )editar

1 Resposta

0

respondidas 2018-05-10 21:54:40 +0200

imagem do gravatar de Conrado

updated 2018-05-10 22:00:45 +0200

olá Camila Vieira

Dei uma limpada na fórmula para você.

=SE(C7="";"--";SE(C7=0;"Iniciar";SE(C7<18%;"Estudo Inicial";SE(C7<46%;"Reuniões";SE(C7<79%;"Minuta";SE(C7<100%;"Etapa Final";SE(C7=100%;"Concluído";"--")))))))

Ela pode ser escrita assim também:

=SE(C7="";"--";SE(C7=0%;"Iniciar";SE(E(C7>0%;C7<=18%);"Estudo Inicial";SE(E(C7>18%;C7<=46%);"Reuniões";SE(E(C7>46%;C7<=79%);"Minuta";SE(E(C7>79%;C7<=99,9999%);"Etapa Final";SE(C7=100%;"Concluído";"% Maior que 100%")))))))

Desta forma você pode ser mais específicas no seu rank.

editar assinalar como ofensivo Excluir Link mais

Comentários

Muito obrigada, vou testar.

imagem do gravatar de Camilla VieiraCamilla Vieira ( 2018-05-11 14:09:43 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-05-10 14:54:57 +0200

Lidas: 57 vezes

Última atualização: May 10