Pergunte aqui
2

Calc: selecionar todas as células vazias da planilha e excluir deslocando pra esquerda.

perguntadas 2018-07-21 21:49:03 +0100

imagem do gravatar de alison.rm

updated 2019-05-03 14:13:17 +0100

Olá pessoal, Estou tendo dificuldades em algumas coisa no Calc, não quero voltar pro Windows por causa disso... uma delas é essa:

No Excel, depois de converter um PDF em xls, a planilha apresentava células em branco no meio das linhas. Eu selecionava toda a planilha, depois ia em Localizar e Selecionar > Especial > Em Branco. Depois eu apenas excluía essa células em branco: selecionava uma célula em branco, botão direito, excluir, deslocar pra direita:

Descrição da imagem

No Calc não tem nenhuma ferramenta de selecionar células em branco pelo que eu pesquisei, nem essa de deletar várias e deslocar pra esquerda, a não ser se for feito por colunas, mas a planilha em +1000 linhas e muitas colunas, ficando inviável.

Se alguém puder me ajudar, agradeço.

Atte.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

1

respondidas 2018-07-27 04:21:55 +0100

imagem do gravatar de Leandro Vieira

updated 2018-07-28 02:14:26 +0100

Levando em consideração o exemplo, segue uma solução:

Primeiro como são várias colunas e linhas, selecione o cabeçalho, e em alguma célula utilize a função cont.valores para saber até que linha e coluna arrastará função a ser utilizada.

Descrição da imagem

(Desconsidere o campo Loja, foi só para me organizar)

Na célula N4 insira a fórmula =ÍNDICE($B4:$I4;1;CORRESP(0;ÉCÉL.VAZIA($B4:$I4);0))

arraste ela somente na primeira coluna;

A partir da segunda utilize a fórmula, neste caso na célula O4 =ÍNDICE(INDIRETO(ENDEREÇO(LINHA();CORRESP(N4;$B4:$I4;0)+2;4)&":"&ENDEREÇO(LINHA();COLUNA(I4)));1;CORRESP(0;ÉCÉL.VAZIA(INDIRETO(ENDEREÇO(LINHA();CORRESP(N4;$B4:$I4;0)+2;4)&":"&ENDEREÇO(LINHA();COLUNA(I4))));0)) e arraste para o restante da planilha.

Não se esqueça de enumerar o cabeçalho com a quantidade de células preenchidas encontradas com o cont.valores, assim evitará de repetir os mesmos, caso queira a planilha esta disponível para baixar:

C:\fakepath\Excluir vazio de tabela.ods

Qualquer dúvidas, pode comentar, se solucionou o problema também pode marcar a resposta como correta no botão Descrição da imagem, contribuindo na organização do Ask.

editar assinalar como ofensivo Excluir Link mais

Comentários

Agradeço pelo feedback!

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2019-05-07 00:42:51 +0100 )editar
0

respondidas 2019-05-03 06:42:12 +0100

imagem do gravatar de Fabiano

Uma forma de excluir linhas em branco em planilhas do LibreOffice Calc é criando tabelas dinâmicas. Uma forma de remover linhas ou células vazias em planilhas do LibreOffice Calc é criando tabelas dinâmicas.

Selecione a tabela que deseja. Esta tabela tem que ter cabeçalhos (títulos na primeira linha). Vai em Dados > Tabela Dinâmica > Criar... Arraste os campos disponíveis para campos de linha e também para campos de dados. Em campos de dados, duplo clique no cabeçalho e selecione a função Contagem. Em Opções, marque ignorar linhas vazias. Após criar a tabela dinâmica, verifique se o resultado atendeu suas necessidades. Senão, vai fazendo testes até chegar na formatação ideal ou crie várias tabelas dinâmicas. Depois vai copiando seus dados para montar uma nova tabela que satisfaça sua formatação ideal.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-07-21 21:49:03 +0100

Lidas: 2,606 vezes

Última atualização: May 03