Pergunte aqui
1

Funções expressões regulares e funções incorporadas

perguntadas 2018-11-08 15:42:34 +0200

imagem do gravatar de rafaelarlindodias

updated 2019-03-01 18:10:00 +0200

A função quando .* como no exemplo can.* funciona no meu Calc mas no computador do meu amigo não funciona, precisa retirar o . ou seja ficando apenas can.

Descrição da imagem

=SOMASES(C2:C6;A2:A6;"can.*";B2:B6;"<"&MÁXIMO(B2:B6))

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

1

@rafaelarlindodias

Seu problema, acredito eu, seria o ponto após o "can".

Em vez de "can." - deixe "can"

imagem do gravatar de ConradoConrado ( 2018-11-08 18:03:57 +0200 )editar

Então o problema é que no meu LibreOffice precisa do .* (ponto e asterisco) se não da zero e no do meu amigo é contrário não pode ter o . (ponto) somente o * (asterisco) pois se não da zero, queria entender o por que isso esta acontecendo.

imagem do gravatar de rafaelarlindodiasrafaelarlindodias ( 2018-11-08 19:52:40 +0200 )editar

1 Resposta

2

respondidas 2018-11-09 02:49:23 +0200

imagem do gravatar de Grafeno

Boa noite,

O Calc passou a suportar além de expressões regulares, o uso de caracteres curingas em fórmulas. No computador do seu amigo, o " * " está se comportando com um caractere curinga.

Verifique nos dois computadores em Ferramentas >> Opções >> LibreOffice Calc >> Calcular qual das opções abaixo está marcada:

  • Permitir caracteres curingas em fórmulas
  • Permitir expressões regulares em fórmulas

Atte,

editar assinalar como ofensivo Excluir Link mais

Comentários

@Grafeno Muito obrigado.

Era isto que procurava. Obrigado pela dica, valeu mesmo.

Abraços.

imagem do gravatar de rafaelarlindodiasrafaelarlindodias ( 2018-11-09 17:06:13 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-11-08 15:42:34 +0200

Lidas: 58 vezes

Última atualização: Nov 09 '18