Pergunte aqui
0

Média Ponderada

perguntadas 2018-11-22 13:43:38 +0200

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

C:\fakepath\Media ponderada.xlsx

Bom dia. Como obter a média ponderada quando, eventualmente, possam ocorrer texto ao invés de número em alguma das células consideradas. Ver planilha em anexo!

engenheiro.marcio@hotmail.com

Obrigado!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

3 Respostas

0

respondidas 2018-11-22 19:01:55 +0200

imagem do gravatar de Bianchini

Olá parceiros, foi muito útil a ajuda de vcs, a fórmula já inserida e adaptada à milha planilha ficou exatamente conforme abaixo:

=SE(ÉTEXTO(L8);0;L8K8)+SE(ÉTEXTO(L9);0;L9K9)+SE(ÉTEXTO(L10);0;L10K10)+SE(ÉTEXTO(L11);0;L11K11))/(SE(ÉTEXTO(L8);0;K8)+SE(ÉTEXTO(L9);0;K9)+SE(ÉTEXTO(L10);0;K10)+SE(ÉTEXTO(L11);0;K11))

Obrigado Conrado e Gilberto pelas dicas.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2018-11-22 14:54:40 +0200

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Esta fórmula o resultado da 404,97. Copiar e colar em C8

=(SE(B3<A3;0;B3*C3)+SE(B4<A4;0;B4*C4)+SE(B5<A5;0;B5*C5)+SE(B6<A6;0;B6*C6))/(SE(B3<A3;0;B3)+SE(B4<A4;0;B4)+SE(B5<A5;0;B5)+SE(B6<A6;0;B6))

editar assinalar como ofensivo Excluir Link mais

Comentários

Ai vem a questão. Vai utilizar o valor de B3 para dividir ou não? Se sim, dá 314,98.

imagem do gravatar de ConradoConrado ( 2018-11-22 15:45:12 +0200 )editar

Pela pergunta entendi, que se Cx = Saques; Bx é desprezado.

Ola @Conrado, acerte a formula, na planilha Ok, aqui falta a multiplicação entre Bx e SE

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2018-11-22 15:49:35 +0200 )editar
0

respondidas 2018-11-22 14:45:14 +0200

imagem do gravatar de Conrado

Caro Marcio.

No seu caso teria que trabalhar com a condição SE ou criar uma coluna a mais para identificar se é texto ou número o resultado.

Fiz a adaptação da sua fórmula: =((B3SE(ÉNUM(C3);C3;0))+(B4SE(ÉNUM(C4);C4;0))+(B5SE(ÉNUM(C5);C5;0))+(B6SE(ÉNUM(C6);C6;0)))/(B3+B4+B6+B5)

Basta copiar a fórmula e colar na célula C8.

O resultado que você informa na planilha de 404,97, na verdade é 314,98.

Agora, caso sua planilha principal, possuir mais linhas com informações, essa fórmula fica extremamente inviável. O correto seria você alterar o modo de preenchimento da sua planilha, ou acrescentar uma coluna identificando se a informação será calculada ou não. O Arquivo que te envio, ilustra como deveria ficar.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-11-22 13:43:38 +0200

Lidas: 176 vezes

Última atualização: Nov 22 '18