Pergunte aqui
0

Retornar todos os valores maiores que zero - Matricial? calc

perguntadas 2019-02-03 21:27:47 +0100

imagem do gravatar de mrkalvin

updated 2019-02-17 16:58:41 +0100

Tenho na coluna A os nomes e nas colunas B a M os valores. Quero pesquisar por exemplo na coluna E todos os valores maiores que zero e retonar os respectivos nomes e seus valores.

Arquivo de exemplo: C:\fakepath\teste.ods

Alguém pode me ajudar com isso? Obrigado

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

2

respondidas 2019-02-04 16:29:10 +0100

imagem do gravatar de Conrado

@mrkalvin Segue sua planilha com a matricial funcionando

C:\fakepath\15492444678852177.ods

editar assinalar como ofensivo Excluir Link mais

Comentários

obrigado era isso que precisava só fiz uma alteração, onde estava a função "maior" troquei para "menor":

=SEERRO(ÍNDICE(Tabela;MENOR(SE(Col_E>0;LINHA(Col_E)-1);LINHA(A2)-1);1);"")

assim mostra na ordem correta do primeiro para o ultimo item, com o maior começava pelo último item.

imagem do gravatar de mrkalvinmrkalvin ( 2019-02-04 17:49:10 +0100 )editar
1

Ola @Conrado, tinha chegado nesta formula, mas não consegui pegar os valores individuais de cada nome !

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-04 17:54:27 +0100 )editar

@Gilberto Shiavinatto infelizmente o LO não trabalha igual o Excel. No nosso caso precisamos criar a matriz na primeira célula, e depois fazer Ctrl+C e Ctrl+V .... Vai entender

imagem do gravatar de ConradoConrado ( 2019-02-04 18:42:50 +0100 )editar

@mrkalvin Sem problemas amigo. Contente que deu certo.

imagem do gravatar de ConradoConrado ( 2019-02-04 18:43:13 +0100 )editar

Estou fazendo uns teste aqui e surgiu um problema, se eu recorto a 'Tabela' A2:M23

e colo em A10 por exemplo, a formula deixa de funcionar ela muda para:

=SEERRO(ÍNDICE(Tabela;MAIOR(SE(Col_E>$O$2;LINHA(Col_E)-1);LINHA(A10)-1);1);"")

saberia corrigir isso ? Obrigado

imagem do gravatar de mrkalvinmrkalvin ( 2019-02-04 21:55:22 +0100 )editar

consegui corrigir a formula isso com a tabela em a10

=SEERRO(ÍNDICE(Tabela;MENOR(SE(Col_E>0;LINHA(Col_E)-(LINHA($A$10)-1));LINHA(A10)-(LINHA($A$10)-1));1);"")

Agora da pra copiar e colar a tabela em qualquer lugar na planilha

se a tabela estiver em a2 como no arquivo de exemplo original a formula seria assim:

=SEERRO(ÍNDICE(Tabela;MENOR(SE(Col_E>0;LINHA(Col_E)-(LINHA($A$2)-1));LINHA(A2)-(LINHA($A$2)-1));1);"")

se alguém tiver uma sugestão melhor, pode dizer! Obrigado

imagem do gravatar de mrkalvinmrkalvin ( 2019-02-05 01:01:35 +0100 )editar
0

respondidas 2019-02-04 00:07:49 +0100

updated 2019-02-04 02:43:20 +0100

@mrkalvin, não serve por: Dados /Mais filtros / Filtro avançado,

Descrição da imagem

Ou por: Dados Autofiltro,

Descrição da imagem

Descrição da imagem

Outra solução com adição de coluna para trabalho e funções ÍNDICE e CORRESP:

Descrição da imagem

Arquivo do teste

.

Tentei usar a ref. do Excel que passou, mas não consegui fazer pegar >0 só pontuais.

editar assinalar como ofensivo Excluir Link mais

Comentários

Não conhecia essa opção de filtro avançado, achei interessante!

Mas assim não é viável pra mim, onde os valores serão exibidos para o usuário, só tem espaço para uma coluna de nome e uma coluna de valor.

imagem do gravatar de mrkalvinmrkalvin ( 2019-02-04 00:20:32 +0100 )editar

Creio que a solução seria por Macro, porem não tenho conhecimento para tal.

Mas estes valores são dinâmicos, mudam conforme digitação, ou é tipo geração de relatório para distribuição ? Se sim, pode-se ligar as respostas no resultado do filtro avançado.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-04 00:49:28 +0100 )editar

é um campo alimentado pelo usuario não contem formulas nele.

Acho que vou ter que usar uma solução parecida com esse video:

"PROCV que retorna todas as correspondências encontradas"

imagem do gravatar de mrkalvinmrkalvin ( 2019-02-04 00:54:41 +0100 )editar

Vide complemento na resposta.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-04 02:43:40 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-02-03 21:27:47 +0100

Lidas: 28 vezes

Última atualização: Feb 04