Pergunte aqui
1

Contar o número de ocorrências de um valor

perguntadas 2019-02-07 14:09:23 +0200

imagem do gravatar de Dambia

updated 2019-02-17 15:51:19 +0200

Tenho uma lista com nomes de escolas e algumas se repetem. Gostaria de uma formula que contasse quantas escolas tem. Ou seja, quantos Valores a coluna possui.

Usei a formula:

=CONT.SES(REGISTROS.C4:C53;"*")

O resultado foi quantas linhas de escolas há, mas elas se repetem então não foi o número de escolas. Tentei usar =frequencia mas não obtive o resultado também.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Você quer saber quantas Escolas diferentes existem ?

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-07 16:16:25 +0200 )editar

2 Respostas

2

respondidas 2019-02-07 18:02:42 +0200

Pode ser assim também:

Com esta fórmula : =SOMARPRODUTO((B3:B18<>"")/CONT.SE(B3:B18;B3:B18&""))

Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

Consegui com essa fórmula. Agradeço!

imagem do gravatar de DambiaDambia ( 2019-02-08 16:54:56 +0200 )editar

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-08 17:18:01 +0200 )editar

Só mais uma questão. Estou usando essa fórmula:

=SOMARPRODUTO((REGISTROS.C4:C53<>"")/CONT.SE(REGISTROS.C4:C53;REGISTROS.C4:C53&""))

Porém, gostaria também que ela só somasse as que estivessem com "Pública" em outra coluna. Tentei inserir essa fórmula nela, mas não obtive sucesso de nenhuma forma.

; REGISTROS.D4:D53;"Pública"
imagem do gravatar de DambiaDambia ( 2019-02-11 19:52:11 +0200 )editar

Como é texto não é SOMAR é CONTAR

=CONT.SE(D4:D53;"Pública")

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-11 20:02:58 +0200 )editar

A formula que funcionou foi a SOMAR que você mesmo disponibilizou.

A questão é que é a mesma fórmula porém que resultasse apenas nas que estivessem como PÚBLICA em

REGISTROS.D4:D53
imagem do gravatar de DambiaDambia ( 2019-02-11 20:58:08 +0200 )editar
0

respondidas 2019-02-07 16:40:28 +0200

imagem do gravatar de Conrado

updated 2019-02-07 16:51:14 +0200

editar assinalar como ofensivo Excluir Link mais

Comentários

1

@Conrado, obrigado pela dica, exclui a resposta errada.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-02-07 17:51:20 +0200 )editar

baixei o arquivo, mas infelizmente não consegui com nenhuma dessas 3. Já havia inclusive olhado essa matéria do Office. De qualquer forma, agradeço!

imagem do gravatar de DambiaDambia ( 2019-02-08 16:57:13 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-02-07 14:09:23 +0200

Lidas: 76 vezes

Última atualização: Feb 07