Pergunte aqui
0

Realizar somatório de valores de opções enumeradas em lista suspensa

perguntadas 2019-03-15 17:01:42 +0200

imagem do gravatar de rhayssa

updated 2019-03-18 14:32:28 +0200

Boa tarde! É possível fazer o somatório de valores a partir de intervalos listados em lista suspensa? Por exemplo, monto uma tabela sobre quantidade de livros lidos por mês e ao final eu coloco para calcular o total, mas montei uma lista suspensa com os quadrimestres: jan-abr,mai-ago,set-dez. Quero que, quando eu selecione, por exemplo, "jan-abr", na outra célula já apareça o somatório, mas que se eu escolher outro intervalo como "mai-ago", ele apareça um novo somatório. É possível fazer isso?


Estou enviando minha tabela para ver se você consegue entender e me ajudar. C:\fakepath\ASKLIBRE.ods

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Ola @rhayssa, seja bem vinda ao Grupo.

.

Tem como postar um exemplo como esta o arquivo. Suba para a nuvem e poste o link.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-15 20:02:36 +0200 )editar

3 Respostas

1

respondidas 2019-03-18 15:27:40 +0200

imagem do gravatar de Conrado

Olá @rhayssa,

Segue seu arquivo com explicações.

Importante: sempre que precisar inserir novas linhas, insira dentro da tabela já criada.

Arquivo

editar assinalar como ofensivo Excluir Link mais

Comentários

Muito obrigada! :D

imagem do gravatar de rhayssarhayssa ( 2019-03-18 17:25:21 +0200 )editar
0

respondidas 2019-03-15 17:38:36 +0200

imagem do gravatar de mrkalvin

updated 2019-03-18 16:16:40 +0200

Acho que poderia usar "SE" aninhado, onde A1 é a celula com a lista suspensa.

=SE(A1="jan-abr";somases(referente aos meses jan-abr);SE(A1="mai-ago";somases(referente aos meses mai-ago);SE(A1="set-dez";somases(referente aos meses set-dez);"escolha um quadrimestre!")))

Não sei como estruturou a sua tabela, mas pode usar uma desas funções abaixo para fazer o somatório de acordo com o critério dos meses.

SOMASES()

CONT.SE()

CONT.SES()

SOMASE()

CONT.VALORES()


Complemento após enviar o arquivo de exemplo:

segue em anexo uma sugestão: C:\fakepath\mod.ods

em f67:

=SE(E67="JAN-ABR";SOMA(E3:E19);SE(E67="MAI-AGO";SOMA(E20:E42);SE(E67="SET-DEZ";SOMA(E43:E64);"escolha um quadrimestre!")))

em f68:

=SE(E68="JAN-ABR";SOMA(F2:F18);SE(E68="MAI-AGO";SOMA(F19:F41);SE(E68="SET-DEZ";SOMA(F42:F63);"escolha um quadrimestre!")))

Mas o ideal era deixar uma quantidade fixa de linhas por mês, porque se vc remover ou incluir linhas pode ser que precise editar a formula manualmente para corrigir os intervalos da somatoria.

Ali onde esta escrito "escolha um quadrimestre!" pode deixar só as "" se não quiser nenhum texto aparecendo, ou pode escrever outra coisa, não esqueça de deixar com as aspas, mesmo em branco : ""

editar assinalar como ofensivo Excluir Link mais

Comentários

Muito Obrigada! :D

imagem do gravatar de rhayssarhayssa ( 2019-03-18 17:25:31 +0200 )editar
0

respondidas 2019-03-19 20:50:30 +0200

updated 2019-03-19 22:50:37 +0200

Uma alternativa sem criação de tabela de parâmetros:

Em F67 =SOMA(SE(E(OU($B$3:$B$64=ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;1;1);DATA(2019;5;1);DATA(2019;9;1));$B$3:$B$64>ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;1;1);DATA(2019;5;1);DATA(2019;9;1)));OU($B$3:$B$64<ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;4;30);DATA(2019;8;31);DATA(2019;12;31));$B$3:$B$64=ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;4;30);DATA(2019;8;31);DATA(2019;12;31))));$E$3:$E$64;0))

E em F68 =SOMA(SE(E(OU($B$3:$B$64=ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;1;1);DATA(2019;5;1);DATA(2019;9;1));$B$3:$B$64>ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;1;1);DATA(2019;5;1);DATA(2019;9;1)));OU($B$3:$B$64<ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;4;30);DATA(2019;8;31);DATA(2019;12;31));$B$3:$B$64=ESCOLHER(SE(E67="JAN-ABR";1;SE(E67="MAI-AGO";2;SE(E67="SET-DEZ";3;"")));DATA(2019;4;30);DATA(2019;8;31);DATA(2019;12;31))));$F$3:$F$64;0))

Após digitar de Ctrl+Shift+Enter

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-03-15 17:01:42 +0200

Lidas: 42 vezes

Última atualização: Mar 19