Pergunte aqui
0

Calcular hora extra - formatada como hora? Calc

perguntadas 2019-03-22 02:59:27 +0200

imagem do gravatar de mrkalvin

updated 2019-03-22 12:25:48 +0200

Não estou conseguindo calcular as horas extras com a célula formatada como hora.

a formula que uso é a seguinte:

=ARRED( ( Salário base / Total de horas mensais ) * Adicional de horas extras * Horas extras efetuadas ; 2 )

O erro está em "Horas extras efetuadas".

se eu uso como um número ele efetua o calculo normalmente. EX: 9 (nove horas)

se eu uso o formato com horas, o valor fica errado. EX: 09:10:00 (nove horas e dez minutos)

C:\fakepath\hora teste.ods

Como devo proceder?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

@mrkalvin, o adicional de hora extra é 150% ou 50% ?

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-22 11:16:37 +0200 )editar

é 50%, mas pra facilitar o calculo coloco 150%

valor hora extra = valor da hora comum * 1,5

é mais fácil que fazer:

valor hora extra = (valor da hora comum * 0,5) + valor da hora comum
imagem do gravatar de mrkalvinmrkalvin ( 2019-03-22 11:19:35 +0200 )editar

1 Resposta

1

respondidas 2019-03-22 11:54:17 +0200

updated 2019-03-22 11:56:14 +0200

@mrkalvin, considerando a hora mais 50%, faça as alterações:

B3 = 50%

D2 =((B1/B2)*B3+(B1/B2))*(HORA(B4)+(MINUTO(B4)/60))

Esclarecendo para converter formato hora em formato decimal, por exemplo em C12 09:25 a fórmula será =HORA(C12)+MINUTO(C12)/60, o resultado será 9,25


Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Obrigado só um complemento pra adicionar os segundos também

=HORA(C12)+(MINUTO(C12)/60)+(SEGUNDO(C12)/3600)
imagem do gravatar de mrkalvinmrkalvin ( 2019-03-22 12:11:42 +0200 )editar

@mrkalvin, Achei uma formula melhor:

Formato hora * 24 = Formato decimal (célula formato número)

ou

Formato decimal / 24 = Formato hora (célula formato data)

A formula em D2 fica =((B9/B10)*B11+(B9/B10))*(B12*24)

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-22 12:17:37 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-03-22 02:59:27 +0200

Lidas: 33 vezes

Última atualização: Mar 22