Pergunte aqui
1

Contar feriados + domingos em um intervalo de data? Calc

perguntadas 2019-03-24 19:13:53 +0200

imagem do gravatar de mrkalvin

updated 2019-04-04 13:36:02 +0200

Existe alguma fórmula que conta o número de feriados e domingos?

Esta fórmula conta os dias úteis de segunda a sábado:

=DIATRABALHOTOTAL.INTL(B2;B32;11;D3:D32)
onde:
B2 é a data inicial
B32 é a data final
11 apenas o domingo é dia de descanso
D3:D32 é o intervalo com os feriados anotados por mim

Ma qual é a melhor forma de descobir a quantidade de domingos e feriados para utilizar no calculo do Descanso semanal remunerado DSR.

Não posso simplesmente somar domingos com feriados, pois pode ter algum feriado que coincide com o domingo, ai o valor fica errado..

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

1

respondidas 2019-03-24 19:44:09 +0200

updated 2019-03-24 19:46:25 +0200

Acho que a formula é essa:

=DIATRABALHOTOTAL(B2;B23;D3:D32;{1;0;0;0;0;0;0})

esta parte {1;0;0;0;0;0;0}, indica que somente Domingo é não útil.

e =DATADIF(B2;B23;"d") resulta o total de dias entre datas

então DATADIF - DIATRABALHOTOTAL = DOMINGOS+FERIADOS.

editar assinalar como ofensivo Excluir Link mais

Comentários

=DATADIF(B2;B23;"d")

Esta contando um dia a menos

https://ibb.co/K5bRGDh

esta contando 27, mas na verdade sao 28 dias

imagem do gravatar de mrkalvinmrkalvin ( 2019-03-24 20:26:25 +0200 )editar

Pela imagem B2=16/02/18 e B23=06/03/18 então DATADIF é 18 ................

Posso ver o arquivo envie para gilbetoschiavinatto@yahoo.com.br

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-24 20:49:41 +0200 )editar

Obs.: O DATADIF considera como hotel, entrou hoje sai amanhã é um dia, no seu caso, cartão de ponto, as datas inicio e fim trabalharam inteiras então devesse somar 1.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-24 20:54:02 +0200 )editar

Acho que errou a digitação.... ( B23 é B32 )

=DATADIF(B2;B32;"d")+1

Conforme explicação acima.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-24 21:00:55 +0200 )editar

Para Cartão de Ponto, o melhor é usar =DIATRABALHOTOTAL(B2;B32;D3:D32;{0;0;0;0;0;0;0})

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-24 21:09:44 +0200 )editar

@mrkalvin, SOLUCIONADO...

=DIATRABALHOTOTAL(B2;B23;D3:D32;{1;0;0;0;0;0;0}) total de dias entre as duas datas sem os domingos (A)

=CONT.SES(D3:D32;">="&B2;D3:D32;"<="&B32) feriados entre as datas (B)

=CONT.SES(E3:E32;">="&B2;E3:E32;"<="&B32;DIA.DA.SEMANA(E3:E32);1)Ctrl+Shift+Enter domingo que são feriados (C)

o resultado final seria

 A - B + C = dias trabalhados sem os domingos mais os feriados de domingos.

Arquivo teste...

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-03-26 00:24:43 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-03-24 19:13:53 +0200

Lidas: 22 vezes

Última atualização: Mar 26